summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEugene Lamskoy2023-11-23 17:15:50 +0200
committerEugene Lamskoy2023-11-23 17:15:50 +0200
commitcda1def28951dfb67e1ebf100ee9f6d11122f088 (patch)
tree615acf8898ae6b0d0c1dfc840f9a005454127a9c /PKGBUILD
parentf30dcc95d59de8e49f8a9037a9a8dd6a0a370184 (diff)
downloadaur-php80.tar.gz
libxml patch applied
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f71ca46e90d..261025917939 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
###############################################################################
# Generated by arch-phpbs: https://github.com/lamskoy/arch-phpbs
#
-# Maintaining/co-maintaining on AUR: php81 php80 php74 php73 php72 php71 php70 php55 php54 php53
+# Maintaining/co-maintaining on AUR: all packages from php53 up to php82
#
# Thanks to:
#
@@ -9,9 +9,12 @@
# AUR php70 and php71 Co-maintainer: William Gathoye <william@gathoye.be>
# AUR php74 Co-maintainer: Tomasz Gruszka <tompear79@gmail.com>
# AUR php73 Co-maintainer: Matt Harrison <matt@harrison.us.com>
-# AUR php73 Contirubutor: Pierre Schmitz <pierre@archlinux.de>
-# AUR php55 Original maintainer: Raphaël Doursenaud <rdoursenaud@gmail.com>
-# AUR php53 Original maintainer: Felix Yan <felixonmars@archlinux.org>
+# AUR php73 and php56 Contributor: Pierre Schmitz <pierre@archlinux.de>
+# AUR php56 Contributor: Chris Severance aur.severach aATt spamgourmet dott com
+# AUR php56 Contributor: Thore Bödecker <me@foxxx0.de>
+# AUR php56 Contributor: Jörg Schuck <joerg_schuck [at] web.de>
+# AUR php55 Contributor: Raphaël Doursenaud <rdoursenaud@gmail.com>
+# AUR php53 Contriburor: Felix Yan <felixonmars@archlinux.org>
###############################################################################
_phpbase="80"
_suffix=""
@@ -130,6 +133,7 @@ source=(
"php-makefile-patcher.php"
"php-apache.conf"
"https://php.net/distributions/php-${pkgver}.tar.xz"
+ "php-libxml.patch"
"debian-php-8.0.patch"
"php-phpinfo.patch"
"timezonedb-guess.patch"
@@ -197,6 +201,7 @@ makedepends=(
arch=(
)
_patches=(
+ "php-libxml.patch"
"debian-php-8.0.patch"
"php-phpinfo.patch"
"timezonedb-guess.patch"
@@ -392,9 +397,6 @@ url='http://www.php.net'
prepare() {
pushd "php-${pkgver}"
- export CFLAGS="${CFLAGS} -fPIC"
- export CXXFLAGS="${CXXFLAGS} -fPIC"
-
echo "[SED] scripts/phpize.in"
sed -E "s|(includedir[\t ]*=.*/php)|\1${_phpbase}${_suffix}|g" \
-i scripts/phpize.in
@@ -467,8 +469,6 @@ prepare() {
}
_build_sapi() {
- export CFLAGS="${CFLAGS} -fPIC"
- export CXXFLAGS="${CXXFLAGS} -fPIC"
_sapi="${1}"
_commands="${2}"
if (( _sapi == "cli" )); then
@@ -505,7 +505,7 @@ _build_sapi() {
# BUILD them all
################################################################################
build() {
- export CFLAGS="${CFLAGS} -fPIC"
+ export CFLAGS="${CFLAGS} -fPIC"
export CXXFLAGS="${CXXFLAGS} -fPIC"
export EXTENSION_DIR="/usr/lib/${pkgbase}/modules"
if ((_build_openssl_v10_patch)); then
@@ -671,7 +671,7 @@ build() {
}
check() {
- export CFLAGS="${CFLAGS} -fPIC"
+ export CFLAGS="${CFLAGS} -fPIC"
export CXXFLAGS="${CXXFLAGS} -fPIC"
pushd "build-cli"
# Check if sendmail was configured correctly (FS#47600)
@@ -1534,6 +1534,7 @@ sha256sums=('e6b8530d747000eebb0089249ec70a3b14add7b501337046700544883f62b17b'
'ba72fc64f77822755a469314160d5889d5298f4eb5758dd7939dac9b811afe52'
'6d0ad9becb5470ce8e5929d7d45660b0f32579038978496317544c5310281a91'
'216ab305737a5d392107112d618a755dc5df42058226f1670e9db90e77d777d9'
+ 'e757f84d2d72ea39259450c32f3a83c72262da4294152ae3e9fbc0cada622bba'
'c9ab253399e58e24cf23cda5edd72a331b7b9aa9b2ac217b0ee04706cc67e93e'
'558e780e93dfa861a366c49b4d156d8fc43f17898f001ae6033ec63c33d5d41c'
'40bcc1e5058602302198d0925e431495391d8469499593af477f59d84d32f764'