summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJunker2021-04-05 20:39:44 +0700
committerJunker2021-04-05 20:39:44 +0700
commit85d072e07f993ec2c4975de24c48f5c76a1e2a71 (patch)
treebf4018f5516cd0ce71fdaf019a833f08401c26b8 /PKGBUILD
parentb1834839a71168c8d865d093dc009ffa336c13e8 (diff)
downloadaur-phpctags.tar.gz
version 0.9.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5cb3e81a3bf8..bbed2586b041 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# This PKGBUILD is maintained at https://github.com/winged/aur-packages
pkgname=phpctags
-pkgver=0.6.0
+pkgver=0.9.0
pkgrel=1
pkgdesc="An enhanced PHP ctags index generator"
arch=('any')
license=('GPLv2')
url='https://packagist.org/packages/techlivezheng/phpctags'
-depends=('php')
+depends=('php' 'composer')
provides=('phpctags')
conflicts=()
optdepends=()
@@ -16,12 +16,15 @@ optdepends=()
install='phpctags.install'
source=("https://github.com/vim-php/phpctags/archive/$pkgver.zip")
-sha256sums=('0d995dc1c432b7b451b5e2cd03064047d5b30939f9b05b994a4630ea537a5afe')
+md5sums=('b2edf3a9384ac37cf301ad6deabf4ef1')
+
package() {
cd $pkgname-$pkgver
ls -aslh
- make
+ composer update --ignore-platform-req=php
+ php -dphar.readonly=0 buildPHAR.php
+ chmod +x build/phpctags.phar
install -Dm755 build/phpctags.phar "$pkgdir/usr/bin/phpctags"
}