summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabian Klötzl2019-12-05 21:15:04 +0100
committerFabian Klötzl2019-12-05 21:15:04 +0100
commit7e03447cfec1403a91268cc688e8cd4c5dda5f5e (patch)
tree7df50c6e7228af989e915382f788c796bd772cbd /PKGBUILD
downloadaur-7e03447cfec1403a91268cc688e8cd4c5dda5f5e.tar.gz
package phylonium v1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce6e4f67e701
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Fabian Klötzl <fabian-aur@kloetzl.info>
+pkgname=phylonium
+pkgver=1.2
+pkgrel=1
+pkgdesc="Fast and Accurate Estimation of Evolutionary Distances"
+url="https://github.com/evolbioinf/phylonium/"
+license=("GPL3") # "custom:ISC"
+depends=("libdivsufsort" "gsl")
+arch=("i686" "x86_64")
+checkdepends=("glib2")
+source=("https://github.com/EvolBioInf/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('480bb1409cb335498d53e176bfa0b5721f3a417d5de8cfcca935815f1010f4be')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+ make check
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}