summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2014-06-25 23:08:41 +0200
committerCarsten Teibes2014-06-25 23:08:41 +0200
commit06508ac5d045ca306dc53110745ea29e2f1c1c70 (patch)
treea31d4124eb232d8db416395c732a51341b2685d2 /PKGBUILD
parent2d473f889c92f4ae3e4a4eedf164dccfb185adb2 (diff)
downloadaur-06508ac5d045ca306dc53110745ea29e2f1c1c70.tar.gz
Cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 19 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 419cbf59b387..3c97a54d13c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: Tai Chi Minh Ralph Eastwood <tcmreastwood@gmail.com>
-_pkgbase=physfs
-pkgname=$_pkgbase-hg
-pkgver=2.1.0.r1338.aae614cdd005
+_name=physfs
+pkgname=$_name-hg
+pkgver=2.1.0.r1345.29ab417d9453
pkgrel=1
pkgdesc="A library to provide abstract access to various archives (development version)"
arch=('i686' 'x86_64')
@@ -11,27 +11,28 @@ url="http://icculus.org/physfs/"
license=('zlib')
depends=('zlib')
makedepends=('cmake' 'doxygen' 'mercurial')
-provides=("$_pkgbase")
-conflicts=("$_pkgbase")
+provides=("$_name")
+conflicts=("$_name")
source=("hg+http://hg.icculus.org/icculus/physfs")
md5sums=('SKIP')
pkgver() {
- cd $_pkgbase
+ cd $_name
+
# get version from cmake
- local ver="$(grep 'set(PHYSFS_VERSION.*)' CMakeLists.txt | sed 's/[^0-9\.]*//g')"
- printf "%s.r%s.%s" "$ver" "$(hg identify -n)" "$(hg identify -i)"
+ local _ver="$(grep 'set(PHYSFS_VERSION.*)' CMakeLists.txt | sed 's/[^0-9\.]*//g')"
+ printf "%s.r%s.%s" "$_ver" "$(hg identify -n)" "$(hg identify -i)"
}
prepare() {
- cd $_pkgbase
+ cd $_name
# avoid abort in docs target
sed -i 's/-Werror//' CMakeLists.txt
}
build() {
- cd $_pkgbase
+ cd $_name
cmake ./ -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \
-DPHYSFS_BUILD_TEST=OFF -DPHYSFS_BUILD_STATIC=OFF
@@ -39,23 +40,17 @@ build() {
}
package() {
- cd $_pkgbase
+ cd $_name
make DESTDIR="$pkgdir/" install
+ # doc
install -d "$pkgdir"/usr/share/{doc/physfs,man/man3}
install -m644 docs/html/* "$pkgdir"/usr/share/doc/physfs
- install -m644 docs/man/man3/* "$pkgdir"/usr/share/man/man3
-
- # here is probably something with find+xargs the better way™
- for i in accesstime author closeArchive createtime Deinit deprecated \
- description destroy duplicate enumerateFiles extension filesize filetype \
- flush Free info Init length major Malloc minor mkdir modtime opaque \
- openAppend openArchive openRead openWrite patch read readonly Realloc \
- remove seek stat supportsSymlinks tell url version write
- do
- mv "$pkgdir"/usr/share/man/man3/$i.3 "$pkgdir"/usr/share/man/man3/PHYSFS_$i.3
- done
-
+ install -m644 docs/man/man3/PHYSFS_* "$pkgdir"/usr/share/man/man3
+ # prefix manual pages with PHYSFS_
+ find docs/man/man3/ -type f -not \( -name "PHYSFS_*.3" -o -name "_*" \) -printf "%f\0" | \
+ xargs -0 -I{} install -m644 docs/man/man3/{} "$pkgdir"/usr/share/man/man3/PHYSFS_{}
+ # license
install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}