summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2015-03-29 19:07:44 +0200
committerCarsten Teibes2015-03-29 19:07:44 +0200
commitfed5bd8bb27e73754da22556566a741e568de820 (patch)
tree2b3e8b35756deda85f542e4555bb9cff84ce062c /PKGBUILD
parent06508ac5d045ca306dc53110745ea29e2f1c1c70 (diff)
downloadaur-fed5bd8bb27e73754da22556566a741e568de820.tar.gz
Allow build of static library, cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c97a54d13c9..d3129e2261b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: Tai Chi Minh Ralph Eastwood <tcmreastwood@gmail.com>
-_name=physfs
-pkgname=$_name-hg
-pkgver=2.1.0.r1345.29ab417d9453
+pkgname=physfs-hg
+pkgver=2.1.0.r1355.52a7487e505c
pkgrel=1
pkgdesc="A library to provide abstract access to various archives (development version)"
arch=('i686' 'x86_64')
@@ -11,13 +10,13 @@ url="http://icculus.org/physfs/"
license=('zlib')
depends=('zlib')
makedepends=('cmake' 'doxygen' 'mercurial')
-provides=("$_name")
-conflicts=("$_name")
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
source=("hg+http://hg.icculus.org/icculus/physfs")
md5sums=('SKIP')
pkgver() {
- cd $_name
+ cd ${pkgname%-*}
# get version from cmake
local _ver="$(grep 'set(PHYSFS_VERSION.*)' CMakeLists.txt | sed 's/[^0-9\.]*//g')"
@@ -25,22 +24,22 @@ pkgver() {
}
prepare() {
- cd $_name
+ cd ${pkgname%-*}
# avoid abort in docs target
sed -i 's/-Werror//' CMakeLists.txt
}
build() {
- cd $_name
+ cd ${pkgname%-*}
cmake ./ -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \
- -DPHYSFS_BUILD_TEST=OFF -DPHYSFS_BUILD_STATIC=OFF
+ -DPHYSFS_BUILD_TEST=OFF
make all docs
}
package() {
- cd $_name
+ cd ${pkgname%-*}
make DESTDIR="$pkgdir/" install