summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilson E. Alvarez2016-09-03 16:29:34 -0400
committerWilson E. Alvarez2016-09-03 16:29:34 -0400
commit58fafc1c0bfa34628cb46fde277645169fb430c7 (patch)
tree19c06ae66123a7e04852399cb0a3da99201a69a2 /PKGBUILD
parentfdd45b357c86845ab01900ddda798ed06fd20f79 (diff)
downloadaur-58fafc1c0bfa34628cb46fde277645169fb430c7.tar.gz
Dependencies were corrected thanks to Geequlim
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 32 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33032dda3051..5556083b922c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,45 @@
# Maintainer: Wilson E. Alvarez <wilson.e.alvarez@hotmail.com>
+# Contributor: Etzos <supercodingmonkey @ gmail.com>
+# Contributer: Gordin <9ordin @t gmail dot com>
+# Contributor: Geequlim <geequlim@gmail.com>
pkgname=physicseditor
pkgver=1.5.2
-pkgrel=1
+pkgrel=2
pkgdesc="Physics editor for certain game engines such as Cocos2D-X, Corona SDK, etc."
arch=('x86_64')
-url="http://www.codeandweb.com"
-license=('custom:physicseditor')
-install='physicseditor.install'
-depends=('glib2' 'hicolor-icon-theme' 'desktop-file-utils' 'shared-mime-info')
-source=("https://www.codeandweb.com/download/physicseditor/${pkgver}/PhysicsEditor-${pkgver}-ubuntu64.deb")
+url="http://www.codeandweb.com/physicseditor"
+license=("custom:$pkgname")
+install="$pkgname.install"
+depends=('shared-mime-info' 'hicolor-icon-theme' 'desktop-file-utils' 'grantlee-qt5'
+ 'gcc-libs-multilib' 'qt5-svg' 'qt5-declarative' 'qt5-imageformats'
+ 'qt5-quickcontrols')
+source=("https://www.codeandweb.com/download/$pkgname/${pkgver}/PhysicsEditor-${pkgver}-ubuntu64.deb")
md5sums=('05c3267ab57964659776ecc31557ee40')
build() {
- ar -xv "PhysicsEditor-${pkgver}-ubuntu64.deb"
- tar -xvf data.tar.xz
+ ar -x "PhysicsEditor-${pkgver}-ubuntu64.deb"
}
package() {
- # Program
- mv ${srcdir}/usr ${pkgdir}
- # License
- install -Dm644 "${pkgdir}/usr/share/physicseditor/documents/LicenseAgreement.html" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LicenseAgreement.html"
+ cd ${srcdir}/
+
+ # Extract to the $pkgdir.
+ tar xJf data.tar.xz -C "${pkgdir}/"
+
+ # Enter $pkgdir.
+ cd ${pkgdir}/usr/lib/$pkgname/
+
+ # Delete all the extra lib folders.
+ rm -rf generic/ grantlee/ iconengines/ imageformats/ platforminputcontexts/ platforms/ \
+ QtGraphicalEffects/ QtQml/ QtQuick/ QtQuick.2/ xcbglintegrations/
+
+ # Delete the useless lib files.
+ rm -rf libGrantlee* libicudata* libicui18n* libicuuc* libQt5*
+
+ # Get rid of the Qt configuration that messes up LD_LIBRARY_PATH.
+ rm -rf qt.conf
+
+ install -Dm644 "${pkgdir}/usr/share/$pkgname/documents/LicenseAgreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LicenseAgreement.txt"
}