summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2019-12-18 11:39:04 +0100
committerHans-Nikolai Viessmann2019-12-18 11:39:04 +0100
commitb63b1731165db8aefe66b329a174668d8a28ece2 (patch)
treeb4d2f850638bc0fe86c9607dd541138f71ca9e22 /PKGBUILD
parentc5be0abb943bbbed9bf73e9e97f06ebe4804f27d (diff)
downloadaur-b63b1731165db8aefe66b329a174668d8a28ece2.tar.gz
add missing PAM config file
Based on PAM config file included with repo release of physlock Thanks @ber_t!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e50b7540b12..af32b54c8cf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=physlock-git
_pkgname='physlock'
-pkgver=v11.r35.g15744f5
-pkgrel=3
+pkgver=v13.r5.g4541222
+pkgrel=1
pkgdesc="lightweight linux console locking tool"
arch=('x86_64')
license=('GPL')
@@ -14,8 +14,10 @@ depends=('pam')
makedepends=('git')
provides=('physlock')
conflicts=('physlock')
-source=("${_pkgname}::git+${url}.git")
-sha512sums=('SKIP')
+source=("${_pkgname}::git+${url}.git"
+ 'physlock.pam')
+sha512sums=('SKIP'
+ '51f35b2b736d8b601a6ea42c038ab0f498225ce4e392eeb35fdcec4a51a7a492a836de451a28565a27dea694a4a29ac4de7ea2c8852bba63cad58710641557fe')
pkgver() {
cd "$_pkgname"
@@ -26,12 +28,11 @@ pkgver() {
}
build() {
- cd "${_pkgname}"
- make PREFIX="/usr"
+ make PREFIX="/usr" -C "${_pkgname}"
}
package() {
- cd "$_pkgname"
- make DESTDIR="${pkgdir}" PREFIX="/usr" install
+ install -D -m 644 physlock.pam "$pkgdir/etc/pam.d/physlock"
+ make DESTDIR="${pkgdir}" PREFIX="/usr" -C "${_pkgname}" install
}