summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Merritt2018-12-15 22:35:09 +0000
committerBen Merritt2018-12-18 04:53:44 +0000
commit34376e414ecf82cf1961604ad713d59776f98a42 (patch)
tree5a420b88a0a4b60819f01602132a0faf54f637cd /PKGBUILD
parent9edf5584d3ee4ffcd6200dd84252545622539462 (diff)
downloadaur-34376e414ecf82cf1961604ad713d59776f98a42.tar.gz
Update to work with more recent Bluetooth stacks
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 20 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d272b2f2cff..82d2d710afcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,36 @@
-# Maintainer: Jesse Jaara <jesse.jaara: gmail.com>
+# Maintainer: Ben Merritt <blm768@gmail.com>
+# Contributor: Jesse Jaara <jesse.jaara: gmail.com>
pkgname=pi-bluetooth
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="Services, firmware and udev rules to get integrated bluetooth running in Raspberry Pi 3"
arch=('armv6h' 'armv7h' 'aarch64')
url=""
license=('multiple')
-depends=('hciattach-rpi3')
+depends=('bluez-utils')
install=pi-bluetooth.install
-source=(BCM43430A1.hcd
- brcm43438.service
- LICENCE.broadcom_bcm43xx
- 50-bluetooth-hci-auto-poweron.rules)
-md5sums=('b95ee9032a723daa25ab9608a515e984'
- '89d9171e5693d7d3b0a3ee1710dcbe0c'
- '3160c14df7228891b868060e1951dfbc'
- '53bcbedd38f7a83920677228e45323b6')
+source=(
+ https://raw.githubusercontent.com/RPi-Distro/bluez-firmware/master/broadcom/BCM43430A1.hcd
+ https://raw.githubusercontent.com/RPi-Distro/bluez-firmware/master/broadcom/BCM4345C0.hcd
+ LICENCE.broadcom_bcm43xx
+ brcm43438.service
+)
+sha256sums=(
+ '8dd70b9003d39cb6175b4f3cd509666dad66ad23d3be1a68385817fb814c8930'
+ '042a8c234beaa9abb8d6156430e44af983f861036e1d54ffe8cabcc0dab76a43'
+ 'b16056fc91b82a0e3e8de8f86c2dac98201aa9dc3cbd33e8d38f1b087fcec30d'
+ 'b4a84d669984424c7994c5a4bcbf65e1818b04c65849ac4d6ed56592a8075ec7'
+)
package() {
cd "${srcdir}"
- mkdir -p "${pkgdir}/usr/lib/systemd/system"
- mkdir -p "${pkgdir}/etc/firmware"
- mkdir -p "${pkgdir}/etc/udev/rules.d"
+ mkdir -p "${pkgdir}/usr/lib/firmware"
mkdir -p "${pkgdir}/usr/share/licences"
+ mkdir -p "${pkgdir}/usr/lib/systemd/system"
- cp BCM43430A1.hcd "${pkgdir}/etc/firmware/"
- cp brcm43438.service "${pkgdir}/usr/lib/systemd/system/"
- cp 50-bluetooth-hci-auto-poweron.rules "${pkgdir}/etc/udev/rules.d/"
+ cp BCM43430A1.hcd BCM4345C0.hcd "${pkgdir}/usr/lib/firmware/"
cp LICENCE.broadcom_bcm43xx "${pkgdir}/usr/share/licences/"
+ cp brcm43438.service "${pkgdir}/usr/lib/systemd/system/"
}