summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormax.bra2022-02-06 21:52:51 +0100
committermax.bra2022-02-06 21:52:51 +0100
commit5443953852579079d61e557c702f94d7706c2559 (patch)
tree27bc44a6bdd3061539b6fff28d08d736e7dfa96a /PKGBUILD
parent39e47df7058093f3f7148196a93a4a2482ba2edb (diff)
downloadaur-5443953852579079d61e557c702f94d7706c2559.tar.gz
license update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c2b24505601..321635a78129 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ _now=`date +%N`
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
pkgdesc="The Pi-hole FTL engine"
url="https://github.com/pi-hole/FTL"
-license=('EUPL-1.1')
+license=('EUPL-1.2')
depends=('nettle' 'gmp' 'libidn')
makedepends=('cmake' 'sqlite')
conflicts=('dnsmasq')
@@ -59,6 +59,9 @@ package() {
install -dm755 "$pkgdir/usr/lib/systemd/system/multi-user.target.wants"
ln -s ../$_servicename.service "$pkgdir/usr/lib/systemd/system/multi-user.target.wants/$_servicename.service"
+ install -dm755 "$pkgdir"/usr/share/licenses/pihole
+ install -Dm644 "$_pkgname"-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/pihole/Pi-hole-FTL
+
# ver. 5.0 dnamasq dropin support
ln -s ./pihole-FTL "$pkgdir/usr/bin/dnsmasq"
}