summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2017-07-04 19:21:22 -0400
committergraysky2017-07-04 19:21:22 -0400
commitbfb18dd7ce4e91259cbc5ffafecbf4e3c9cfc78c (patch)
treeafa805979b19ad5d23a7a2f6eaea852c7184b35b /PKGBUILD
parent67ede212cb191bbc72c0d03041f5cc235b20b6b3 (diff)
downloadaur-bfb18dd7ce4e91259cbc5ffafecbf4e3c9cfc78c.tar.gz
preserve user edits to dnsmasq.d files on update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 305ed3db1413..696820bdf65a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=pi-hole-server
_pkgname=pi-hole
pkgver=3.1
-pkgrel=9
+pkgrel=10
_wwwpkgname=AdminLTE
_wwwpkgver=3.1
pkgdesc='The Pi-hole is an advertising-aware DNS/Web server. Arch adaptation for lan wide DNS server.'
@@ -20,7 +20,8 @@ optdepends=(
)
conflicts=('pi-hole-standalone')
install=$pkgname.install
-backup=('etc/pihole/whitelist.txt' 'etc/pihole/blacklist.txt')
+backup=('etc/pihole/whitelist.txt' 'etc/pihole/blacklist.txt'
+'etc/dnsmasq.d/01-pihole.conf' 'etc/dnsmasq.d/02-pihole.conf')
source=(pihole-$pkgver.tar.gz::https://github.com/$_pkgname/$_pkgname/archive/v$pkgver.tar.gz
admin-$_wwwpkgver.tar.gz::https://github.com/$_pkgname/$_wwwpkgname/archive/v$_wwwpkgver.tar.gz
@@ -297,11 +298,16 @@ package() {
install -Dm644 /dev/null "$pkgdir"/etc/pihole/whitelist.txt
install -Dm644 /dev/null "$pkgdir"/etc/pihole/blacklist.txt
- install -Dm644 configuration "$pkgdir"/usr/share//pihole/doc/configuration
+ install -Dm644 configuration "$pkgdir"/usr/share/pihole/doc/configuration
- install -Dm644 dnsmasq.main "$pkgdir"/usr/share/pihole/configs/dnsmasq.main
+ install -Dm644 dnsmasq.main "$pkgdir"/usr/share/pihole/configs/dnsmasq.example.conf
+
+ # note the redundancy is due to sed magic post-install
+ install -Dm644 dnsmasq.include "$pkgdir"/usr/share/pihole/configs/01-pihole.example.conf
install -Dm644 dnsmasq.include "$pkgdir"/etc/dnsmasq.d/01-pihole.conf
+ install -Dm644 dnsmasq.local "$pkgdir"/usr/share/pihole/configs/02-pihole.example.conf
install -Dm644 dnsmasq.local "$pkgdir"/etc/dnsmasq.d/02-pihole.conf
+
install -Dm644 lighttpd.conf "$pkgdir"/usr/share/pihole/configs/lighttpd.example.conf
install -Dm644 nginx.pi-hole.conf "$pkgdir"/usr/share/pihole/configs/nginx.example.conf