summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormax.bra2021-02-01 13:12:49 +0100
committermax.bra2021-02-01 13:12:49 +0100
commite4c70bc5e14f75c089f983d5f89960d9c5a7a869 (patch)
tree6721ced393b7014bcf7bb6cc858a2b49959fcd23 /PKGBUILD
parentb027b841290363dc50b9f7109dadadfc2eb17833 (diff)
downloadaur-e4c70bc5e14f75c089f983d5f89960d9c5a7a869.tar.gz
standard server log
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a4316753f65..efc4499d6ce5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=pi-hole-standalone
_pkgname=pi-hole
pkgver=5.2.4
-pkgrel=1
+pkgrel=2
_now=`date +%N`
pkgdesc='The Pi-hole is an advertising-aware DNS/Web server. Arch alteration for standalone PC.'
arch=('any')
@@ -17,17 +17,23 @@ backup=('etc/dnsmasq.d/01-pihole.conf')
source=($pkgname-core-$pkgver.tar.gz::https://github.com/$_pkgname/$_pkgname/archive/v$pkgver.tar.gz
arch-server-core-$pkgver-$_now.patch::"https://raw.githubusercontent.com/max72bra/pi-hole-standalone-archlinux-customization/master/arch-server-core-$pkgver.patch"
dnsmasq.include
+ $_pkgname.tmpfile
$_pkgname-gravity.service
$_pkgname-gravity.timer
+ $_pkgname-logtruncate.service
+ $_pkgname-logtruncate.timer
mimic_setupVars.conf.sh
mimic_basic-install.sh
piholeDebug.sh)
sha256sums=('550de24beae4d701c0486208083e06efa5476fb87a729fe39ddf7fc3cac83a75'
'92aad8cd123d8509548843641e0c8c0b48bd0e7cbfd56bb9486be61239c8cc1c'
- '2d0caa2d0c6a2d7b74da8456d6df9b15a104ab8c68a24403de2906d329ef2cd5'
+ '96c1fb8b15e1d0e99c18dc768f5dc3d4991184fb2631af84c5e2111028bc5287'
+ '6da6bba6cfac4e87a1f1e8e1488b71858ac6feb0a2e327470a58d8f1e9ad8cbf'
'9b72d7769036f8f4bb7121968d2ae4bdba427e4b16787ce340205a5f62b45c7c'
'5228b4f923eab7784952a0fd6da895e7bff2f80a7f91c4a7c6350491dfdbb2e8'
+ '88e3c78bbeaf5dc1100df65202ded8207877954a96bdf1b0ab3d9990d9fa759f'
+ 'ff507ce58c9492cce57e947696e1b814469fc2d856a1e303c6e68f98c62ebf46'
'8119a46428bdbe00a312b14f3f0c364248b120f2569c9f2b6af2ef1a64fdfe94'
'fa8d91d07b75f21076e5334c46d323cbc3dcf9a33fe9b8b4e032dbc5c979a6d2'
'73a8362f7a3eac91c77efbbcb4910ff079203bb5f829e32ecf3391d017117bb8')
@@ -43,6 +49,7 @@ package() {
install -dm755 "$pkgdir"/opt/pihole
install -Dm755 $_pkgname-$pkgver/gravity.sh "$pkgdir"/opt/pihole/gravity.sh
+ install -Dm755 $_pkgname-$pkgver/advanced/Scripts/piholeLogFlush.sh "$pkgdir"/opt/pihole/piholeLogFlush.sh
install -Dm755 $_pkgname-$pkgver/advanced/Scripts/list.sh "$pkgdir"/opt/pihole/list.sh
install -Dm755 $_pkgname-$pkgver/advanced/Scripts/webpage.sh "$pkgdir"/opt/pihole/webpage.sh
install -Dm755 $_pkgname-$pkgver/advanced/Scripts/wildcard_regex_converter.sh "$pkgdir"/opt/pihole/wildcard_regex_converter.sh
@@ -64,10 +71,15 @@ package() {
install -Dm644 $_pkgname-$pkgver/advanced/dnsmasq.conf.original "$pkgdir"/etc/dnsmasq.conf
install -Dm644 dnsmasq.include "$pkgdir"/etc/dnsmasq.d/01-pihole.conf
- install -dm755 "$pkgdir/usr/lib/systemd/system/multi-user.target.wants"
+ install -Dm644 pi-hole.tmpfile "$pkgdir"/usr/lib/tmpfiles.d/pi-hole.conf
+
install -Dm644 "$_pkgname-gravity.timer" "$pkgdir/usr/lib/systemd/system/$_pkgname-gravity.timer"
install -Dm644 "$_pkgname-gravity.service" $pkgdir/usr/lib/systemd/system/$_pkgname-gravity.service
+ install -Dm644 "$_pkgname-logtruncate.timer" "$pkgdir/usr/lib/systemd/system/$_pkgname-logtruncate.timer"
+ install -Dm644 "$_pkgname-logtruncate.service" $pkgdir/usr/lib/systemd/system/$_pkgname-logtruncate.service
+ install -dm755 "$pkgdir/usr/lib/systemd/system/multi-user.target.wants"
ln -s ../$_pkgname-gravity.timer "$pkgdir/usr/lib/systemd/system/multi-user.target.wants/$_pkgname-gravity.timer"
+ ln -s ../$_pkgname-logtruncate.timer "$pkgdir/usr/lib/systemd/system/multi-user.target.wants/$_pkgname-logtruncate.timer"
install -dm775 "$pkgdir"/etc/pihole
install -dm755 "$pkgdir"/usr/share/pihole/configs