summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2021-01-15 06:56:44 +0100
committerChristopher Arndt2021-01-15 06:56:44 +0100
commit5270af044e1ba251b65918bb1e70e4eab0865a40 (patch)
tree7e71dd65e9c36f2b032b9ebc07f439745095c614 /PKGBUILD
parent85ab4fc9784cfbb0d99d6afcbe5985ad7bff3168 (diff)
downloadaur-5270af044e1ba251b65918bb1e70e4eab0865a40.tar.gz
Update to Pianoteq 7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 35 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 758877e5c255..477d6cb32cb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: Simon Thorpe <simon@hivetechnology.com.au>
pkgname=pianoteq-standard-trial-bin
-pkgver=6.7.3
+pkgver=7.1.0
pkgrel=1
-pkgdesc="Virtual piano instrument using physical modelling synthesis. Both standalone and plugin versions."
-arch=('i686' 'x86_64')
+pkgdesc="Physical modelling piano instrument as a standalone program and VST2 and LV2 plugins. STANDARD trial version"
+arch=('x86_64' 'armv7h' 'aarch64')
url="https://www.pianoteq.com/home"
license=('custom')
-groups=('lv2-plugins' 'pro-audio')
-depends=('alsa-lib' 'freetype2' 'libxext')
+groups=('lv2-plugins' 'pro-audio' 'vst-plugins')
+depends=('alsa-lib' 'libx11')
makedepends=('gendesk' 'wget' 'p7zip')
optdepends=('jack: JACK support for stand-alone application')
provides=("${pkgname%-*}")
@@ -21,7 +21,7 @@ sha256sums=('94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3')
# Define the target archive filename:
_downfname="pianoteq_linux_trial_v${pkgver//./}.7z"
# Define its checksum:
-_downsha256sum='9c74c0aa8b0e26a0b4567470dbfc55a59eb2d36bef6aee8281f36682237f007b'
+_downsha256sum='858ab31b86627b5c8dbb8850825c8bd71ce666124d58f7760ebebd67b7114627'
prepare() {
# Download archive, if neccessary
@@ -38,43 +38,57 @@ prepare() {
fi
# Check integrity:
- echo $_downsha256sum "${srcdir}/${_downfname}" | sha256sum -c || { echo 'Checksum failed!'; exit 1; }
+ echo $_downsha256sum "${srcdir}/${_downfname}" | \
+ sha256sum -c || { echo 'Checksum failed!'; exit 1; }
# Extract:
7z x -y "${srcdir}/${_downfname}"
# Generate Desktop Entry:
- gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name='Pianoteq 6' --exec='Pianoteq\ 6' --categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
+ gendesk -f -n \
+ --pkgname "$pkgname" \
+ --pkgdesc "$pkgdesc" \
+ --name='Pianoteq 7' \
+ --exec="'Pianoteq 7'" \
+ --categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
}
package() {
# Define architecture specific file directory:
- if [[ "$CARCH" == i686 ]]; then
- archdir=i386
- else
- archdir=amd64
+ if [[ "$CARCH" == "x86_64" ]]; then
+ archdir='x86-64bit'
+ elif [[ "$CARCH" == "armv7h" ]]; then
+ archdir='arm-32bit'
+ elif [[ "$CARCH" == "aarch64" ]]; then
+ archdir='arm-64bit'
fi
# Install program files:
- install -Dm 755 "$srcdir/Pianoteq 6/$archdir/Pianoteq 6" "$pkgdir/usr/bin/Pianoteq 6"
- install -Dm 755 "$srcdir/Pianoteq 6/$archdir/Pianoteq 6.so" "$pkgdir/usr/lib/vst/Pianoteq 6.so"
- cd "$srcdir/Pianoteq 6/$archdir/Pianoteq 6.lv2"
+ install -Dm 755 "$srcdir/Pianoteq 7/$archdir/Pianoteq 7" \
+ "$pkgdir/usr/bin/Pianoteq 7"
+ install -Dm 755 "$srcdir/Pianoteq 7/$archdir/Pianoteq 7.so" \
+ "$pkgdir/usr/lib/vst/Pianoteq 7.so"
+ cd "$srcdir/Pianoteq 7/$archdir/Pianoteq 7.lv2"
for i in *; do
- install -D "$i" "$pkgdir/usr/lib/lv2/Pianoteq 6.lv2/$i"
+ install -D "$i" "$pkgdir/usr/lib/lv2/Pianoteq 7.lv2/$i"
done
cd $srcdir
# Install desktop launcher:
- install -Dm 644 "$srcdir/pianoteq_icon_128.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
- install -Dm 644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/${pkgname%-*}.desktop"
+ install -Dm 644 "$srcdir/pianoteq_icon_128.png" \
+ "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm 644 "$srcdir/$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/${pkgname%-*}.desktop"
# Install the license:
install -d "$pkgdir/usr/share/licenses/$pkgname"
- install -m 644 Pianoteq\ 6/*Licence* "$pkgdir/usr/share/licenses/$pkgname/"
+ install -m 644 "Pianoteq 7"/*Licence* \
+ "$pkgdir/usr/share/licenses/$pkgname/"
# Install the Documentation:
- install -D "Pianoteq 6/README_LINUX.txt" "$pkgdir/usr/share/doc/${pkgname%-*}/README_LINUX.txt"
- cd "$srcdir/Pianoteq 6/Documentation"
+ install -D "Pianoteq 7/README_LINUX.txt" \
+ "$pkgdir/usr/share/doc/${pkgname%-*}/README_LINUX.txt"
+ cd "$srcdir/Pianoteq 7/Documentation"
for i in *; do
install -D "$i" "$pkgdir/usr/share/doc/${pkgname%-*}/$i"
done