summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2022-12-30 22:50:29 +0100
committerChristopher Arndt2022-12-30 22:50:29 +0100
commitca1b314a216fa540ff5e42ed03b4bfcb6b8b423c (patch)
treefde1e884b6b11d7f30041e85b9d60a820b6f4e27 /PKGBUILD
parent40abb7e5242e7e0f2dc7a12fdcdbf4254cec294d (diff)
downloadaur-ca1b314a216fa540ff5e42ed03b4bfcb6b8b423c.tar.gz
Update to version 8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD86
1 files changed, 41 insertions, 45 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 815dec7c9980..2a8a58fba191 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,70 +3,66 @@
# Contributor: Simon Thorpe <simon@hivetechnology.com.au>
pkgname=pianoteq-standard-trial-bin
-pkgver=7.5.4
+pkgver=8.0.5
pkgrel=1
-pkgdesc="Physical modelling piano instrument as a standalone program and VST2 and LV2 plugins. STANDARD trial version"
-arch=('x86_64' 'armv7h' 'aarch64')
+_name="Pianoteq ${pkgver%%.*}"
+pkgdesc='Physical modelling piano instrument standalone program, VST2 and LV2 plugin. STANDARD trial version'
+arch=(x86_64 armv7h aarch64)
url="https://www.modartt.com/pianoteq"
-license=('custom')
-groups=('lv2-plugins' 'pro-audio' 'vst-plugins')
-depends=('alsa-lib' 'libx11')
-makedepends=('gendesk')
-optdepends=('jack: JACK support for stand-alone application')
-provides=("${pkgname%-*}")
-conflicts=("${pkgname%-*}" 'pianoteq-standard-bin')
+license=(custom)
+groups=(lv2-plugins pro-audio vst-plugins)
+depends=(alsa-lib libx11)
+makedepends=(gendesk)
+optdepends=(
+ 'jack: JACK support for stand-alone application'
+ 'lv2-host: for loading the LV2 plugin'
+ 'vst-host: for loading the VST2 plugin'
+)
+provides=(${pkgname%-*})
+conflicts=(${pkgname%-*} pianoteq-standard-bin)
source=("local://pianoteq_linux_trial_v${pkgver//./}.7z"
'https://www.pianoteq.com/images/logo/pianoteq_icon_128.png')
-sha256sums=('ddadfe48a4c486f0eda8ae4a83813a2a22ef9f9fa3e8937a9ed21bef6bb66dd4'
+sha256sums=('ab15625486e577ccd3323d7e4c87ceb083a19ae8ce189bb1dbfbb627886fb2ac'
'94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3')
prepare() {
+ cd "$_name"
# Generate Desktop Entry:
gendesk -f -n \
- --pkgname "${pkgname%-*}" \
- --pkgdesc "$pkgdesc" \
- --name='Pianoteq 7' \
- --exec="'Pianoteq 7'" \
+ --pkgname=${pkgname%-*} \
+ --pkgdesc="$pkgdesc" \
+ --name="$_name" \
+ --exec="\"$_name\"" \
--categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
}
package() {
- # Define architecture specific file directory:
- if [[ "$CARCH" == "x86_64" ]]; then
- archdir='x86-64bit'
- elif [[ "$CARCH" == "armv7h" ]]; then
- archdir='arm-32bit'
- elif [[ "$CARCH" == "aarch64" ]]; then
- archdir='arm-64bit'
+ cd "$_name"
+
+ # Define architecture specific directory:
+ if [[ "$CARCH" == x86_64 ]]; then
+ _archdir=x86-64bit
+ elif [[ "$CARCH" == armv7h ]]; then
+ _archdir=arm-32bit
+ elif [[ "$CARCH" == aarch64 ]]; then
+ _archdir=arm-64bit
fi
- # Install program files:
- install -Dm 755 "$srcdir/Pianoteq 7/$archdir/Pianoteq 7" \
- "$pkgdir/usr/bin/Pianoteq 7"
- install -Dm 755 "$srcdir/Pianoteq 7/$archdir/Pianoteq 7.so" \
- "$pkgdir/usr/lib/vst/Pianoteq 7.so"
- cd "$srcdir/Pianoteq 7/$archdir/Pianoteq 7.lv2"
- for i in *; do
- install -D "$i" "$pkgdir/usr/lib/lv2/Pianoteq 7.lv2/$i"
- done
- cd $srcdir
+ # Install executables and plugins:
+ install -Dm 755 "$_archdir/$_name" -t "$pkgdir"/usr/bin
+ ln -sf "$_name" "$pkgdir"/usr/bin/${pkgname%-bin}-${pkgver%%.*}
+ install -Dm 755 "$_archdir/$_name.so" -t "$pkgdir"/usr/lib/vst
+ install -Dm 755 "$_archdir/$_name.lv2"/*.so -t "$pkgdir/usr/lib/lv2/$_name.lv2"
+ install -Dm 644 "$_archdir/$_name.lv2"/*.ttl -t "$pkgdir/usr/lib/lv2/$_name.lv2"
# Install desktop launcher:
- install -Dm 644 "$srcdir/pianoteq_icon_128.png" \
- "$pkgdir/usr/share/pixmaps/${pkgname%-*}.png"
- install -Dm 644 "$srcdir/${pkgname%-*}.desktop" \
- "$pkgdir/usr/share/applications/${pkgname%-*}.desktop"
+ install -Dm 644 "$srcdir"/pianoteq_icon_128.png \
+ "$pkgdir"/usr/share/pixmaps/${pkgname%-*}.png
+ install -Dm 644 ${pkgname%-*}.desktop -t "$pkgdir"/usr/share/applications
# Install the license:
- install -d "$pkgdir/usr/share/licenses/$pkgname"
- install -m 644 "Pianoteq 7"/*Licence* \
- "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 *Licence* -t "$pkgdir"/usr/share/licenses/$pkgname
# Install the Documentation:
- install -D "Pianoteq 7/README_LINUX.txt" \
- "$pkgdir/usr/share/doc/${pkgname}/README_LINUX.txt"
- cd "$srcdir/Pianoteq 7/Documentation"
- for i in *; do
- install -D "$i" "$pkgdir/usr/share/doc/${pkgname}/$i"
- done
+ install -Dm 644 README_LINUX.txt Documentation/* -t "$pkgdir"/usr/share/doc/$pkgname
}