summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnish Bhatt2015-07-16 23:34:06 -0700
committerAnish Bhatt2015-07-16 23:34:06 -0700
commit0104d1d29ff798008f88f0d93dce1c10dc67437b (patch)
tree12e7a281526b46803b265a9d514cbbe37c08760b /PKGBUILD
parent3c3d64e056af9cb9adfc4757a6533f07db7c4bf5 (diff)
downloadaur-0104d1d29ff798008f88f0d93dce1c10dc67437b.tar.gz
Enable mlat support in piaware
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b5d33add2f0..bebd1a9a59e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=piaware-git
_gitname=piaware
pkgver=2.1.2.r1.ga1076de
-pkgrel=1
+pkgrel=2
pkgdesc="Client-side package and programs for forwarding ADS-B data to FlightAware"
@@ -12,17 +12,20 @@ arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://github.com/flightaware/piaware"
license=('BSD')
-depends=('dump1090-fa-git' 'tcl' 'tcllib' 'tclx' 'tk' 'tls')
-makedepends=('git' 'autoconf' 'tcl')
+depends=('dump1090-fa-git' 'tcl' 'tcllib' 'tclx' 'tk' 'tls' 'python')
+makedepends=('git' 'autoconf' 'tcl' 'python')
source=('piaware::git+git://github.com/flightaware/piaware'
- 'tcllauncher::git+git://github.com/flightaware/tcllauncher.git')
+ 'tcllauncher::git+git://github.com/flightaware/tcllauncher.git'
+ 'mlat::git+git://github.com/mutability/mlat-client.git')
md5sums=('SKIP'
+ 'SKIP'
'SKIP')
install=piaware-git.install
_gitname=piaware
-_gitname2=tcllauncher
+_gitname2=tcllauncher
+_gitname3=mlat
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -44,6 +47,9 @@ package() {
cd "${srcdir}/${_gitname}"
make install DESTDIR=${pkgdir} SYSTEMD=usr/lib/systemd/system
+ cd "${srcdir}/${_gitname3}"
+ ./setup.py install --prefix="${pkgdir}"/usr
+
chmod -x "${pkgdir}/usr/lib/systemd/system/piaware.service"
rm -rf "${pkgdir}/etc"
}