summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2018-01-03 01:02:22 -0500
committerGI_Jack2018-01-03 01:02:22 -0500
commit074cf24f0a098ab4ef5d70dc14953bf748b4206b (patch)
tree7c7eadbcdda19f85fbf63171d034f0599ab9a42e /PKGBUILD
downloadaur-074cf24f0a098ab4ef5d70dc14953bf748b4206b.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c569301a7e4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+pkgname=pidgin-wechat
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="https://github.com/sbwtw/pidgin-wechat"
+arch=('i686' 'x86_64')
+url="https://github.com/sbwtw/pidgin-wechat"
+license=('WTFPL')
+depends=('libpurple')
+makedepends=('rust' 'clang' 'libpurple')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/sbwtw/pidgin-wechat/archive/${pkgver}.tar.gz")
+sha256sums=('d54ef61822b94ae9b67520adbee99a0648b763f63b9f948d361c1772a3355d9f')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cargo build --release
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 target/release/deps/libwechat.so ${pkgdir}/usr/lib/pidgin/libwechat.so
+}
+