summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-08-27 14:07:47 -0600
committerMark Wagie2020-08-27 14:07:47 -0600
commitfbe4b6e966ead4668fd505a40e8989cf18ea6f2e (patch)
treec6220ef5a946753de1d9e6961d8f4a9c5446212b /PKGBUILD
downloadaur-fbe4b6e966ead4668fd505a40e8989cf18ea6f2e.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28e80b5cca90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=pika-backup
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Simple backups based on borg"
+arch=('x86_64')
+url="https://gitlab.gnome.org/World/pika-backup"
+license=('GPL')
+depends=('borg' 'gtk3')
+makedepends=('cargo' 'meson')
+source=("$url/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+sha256sums=('4f98d22a8132f6d63ae36eba3158ebaf6a24aa0862858c54cb02f6dbcafe5637')
+
+build() {
+ arch-meson "$pkgname-v$pkgver" build
+ meson compile -C build
+}
+
+check() {
+ #meson test -C build
+
+ cd "$pkgname-v$pkgver"
+ cargo test
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}