summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoractionless2019-04-22 01:47:49 +0200
committeractionless2019-04-22 01:47:49 +0200
commite7b21a372cf64e83e39762c5bb835e0f90a65729 (patch)
tree9ef3f794a5a58f1fd7b495e00a0219cf608ea514 /PKGBUILD
parent3654a92533e216b7b168b73feecaedff207f42dd (diff)
downloadaur-e7b21a372cf64e83e39762c5bb835e0f90a65729.tar.gz
update to 1.4.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa0ae9ba864c..63e9196d56d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=1.4.1
+pkgver=1.4.2
pkgrel=1
pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
@@ -11,13 +11,14 @@ license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-md5sums=('c1c476894d1a9e994256dbb0f0c6ebe0')
+md5sums=('8117dc826b853775356de93ece115586')
depends=(
'pyalpm'
'git'
)
optdepends=(
'asp: for ABS support in -G/--getpkgbuild operation'
+ 'python-pysocks: for socks5 proxy support'
)
conflicts=('pikaur-git')
@@ -29,7 +30,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit 2
- python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ python3 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
for langmo in $(cd ./locale && ls ./*.mo); do
lang=$(sed -e 's/.mo$//' <<< "${langmo}")
install -Dm644 "locale/${langmo}" "$pkgdir/usr/share/locale/${lang}/LC_MESSAGES/pikaur.mo"