summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjakob2017-04-24 03:02:13 -0400
committerjakob2017-04-24 03:02:13 -0400
commit0118a7eae11bf5bda482b5c1511fafd280e7aab0 (patch)
tree9e9c68d961429e9c1b11daf6f1c425d28d2790c3 /PKGBUILD
parent7faecb4803ffee76f3529aa6e559f5a42fe54873 (diff)
downloadaur-0118a7eae11bf5bda482b5c1511fafd280e7aab0.tar.gz
Fixed issue where PINCE attempts to read several metadata files, and updated versioning scheme.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0bf0ae187310..07ef532023a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jakob Kreuze <jakob@memeware.net>
pkgname=pince-git
-pkgver=0.1.0
+pkgver=r642.78d9020
pkgrel=1
pkgdesc="A Linux reverse engineering tool inspired by Cheat Engine."
arch=('any')
@@ -11,12 +11,19 @@ makedepends=()
source=("$pkgname::git+https://github.com/korcankaraokcu/PINCE.git")
md5sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
package() {
cd "$srcdir/$pkgname"
- sed -i "s/\.\/gdb_pince\/gdb-7\.11\.1\/bin\/gdb/\/usr\/bin\/gdb/g" libPINCE/type_defs.py
+ sed -i 's/\.\/gdb_pince\/gdb-7\.11\.1\/bin\/gdb/\/usr\/bin\/gdb/g' libPINCE/type_defs.py
+ sed -i 's/\ssudo python3 PINCE.py/cd \/usr\/share\/PINCE \&\& python PINCE.py/' PINCE.sh
+ sed -i 's/OS=.*/OS="Arch"/' PINCE.sh
install -d "$pkgdir/usr/bin"
+ install PINCE.sh "$pkgdir/usr/bin/pince"
install -d "$pkgdir/usr/share/PINCE"
- install PINCE.py "$pkgdir/usr/share/PINCE"
+ install PINCE.py COPYING AUTHORS THANKS "$pkgdir/usr/share/PINCE"
cp -r GUI libPINCE media pince-non-stop-files "$pkgdir/usr/share/PINCE"
- ln -s "/usr/share/PINCE/PINCE.py" "${pkgdir}/usr/bin/pince"
}