summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjuacrumar2020-09-14 15:31:20 +0200
committerjuacrumar2020-09-14 15:31:20 +0200
commit70bb0d99bd2c61707829689a05a0c10056429bc8 (patch)
treee67de851b2c12a9b9866cd2a53fb1635db56c754 /PKGBUILD
parent20ccddd997977931191a86d0bb62b14dd1479948 (diff)
downloadaur-70bb0d99bd2c61707829689a05a0c10056429bc8.tar.gz
add lhapdf to the deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b084a546ced6..9e24550bde41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,16 @@
pkgname=pineappl
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc='PineAPPL is not an extension of APPLgrid'
arch=('any')
url="https://n3pdf.github.io/pineappl/"
license=('GPL3')
+makedepends=("python-setuptools")
depends=("cargo-c"
"rust"
"python-pkgconfig"
+ "lhapdf"
)
optdepends=()
provides=("pineappl")
@@ -33,6 +35,7 @@ package() {
cd "$pkgname-$pkgver"/pineappl_capi
cargo cinstall --release --prefix=${pkgdir}/usr
cd ..
+ echo "CARGO INSTALL"
# Now install the command-line program
cargo install --path pineappl_cli --root=${pkgdir}/usr
# And the python wrapper