summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTianyu Ge2017-07-07 12:30:11 -0400
committerTianyu Ge2017-07-07 12:30:11 -0400
commit55ae581882472a914adcf928244768820896d2c2 (patch)
tree38183ce379ccd28d30b2b09ab1aad17fe0280fc3 /PKGBUILD
parentc30667bfb0f733b85e429ebb105c9de65e65e969 (diff)
downloadaur-55ae581882472a914adcf928244768820896d2c2.tar.gz
Now generates desktop entry using gendesk.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f87d73ef3e8..671e886cb603 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=pinegrow
pkgver=3.02
-pkgrel=2
+pkgrel=3
pkgdesc='A website development tool for building responsive websites'
arch=('x86_64')
url="https://pinegrow.com"
license=('custom')
-depends_x86_64+=(gtk2 gconf alsa-lib nss libxss libxtst)
+depends_x86_64+=(gtk2 gconf alsa-lib nss libxss libxtst gendesk)
source=("http://download.pinegrow.com/PinegrowLinux64.${pkgver}.zip"
"${url}/Pinegrow_EULA.pdf")
noextract=("Pinegrow_EULA.pdf")
@@ -19,6 +19,8 @@ install=${pkgname}.install
prepare() {
cd "${srcdir}"
+ gendesk --pkgname "$pkgname" --pkgdesc "$pkgdesc"
+
unzip -qqo "PinegrowLinux64.${pkgver}.zip" -d "Pinegrow-${pkgver}"
}
@@ -26,8 +28,7 @@ package() {
cd ${srcdir}
install -D -m644 Pinegrow_EULA.pdf ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md
cd "Pinegrow-${pkgver}"
- printf "[Desktop Entry]\nName=Pinegrow\nComment=Pinegrow Web Editor\nExec=sh -c \"/usr/share/pinegrow/PinegrowLibrary\"\nTerminal=false\nType=Application" > Pinegrow.desktop
install -d ${pkgdir}/usr/share/pinegrow/
cp -R * ${pkgdir}/usr/share/pinegrow/
- desktop-file-install ${pkgdir}/usr/share/pinegrow/Pinegrow.desktop --dir ${pkgdir}/usr/share/applications/
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
}