summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan Knapp2019-04-05 03:08:50 -0700
committerJonathan Knapp2019-04-05 03:08:50 -0700
commitb433ce595eb634e481a692808dcc752d09b84a11 (patch)
treec13143656e5f04f8f7dce3a2dc6451b748a837c2 /PKGBUILD
downloadaur-b433ce595eb634e481a692808dcc752d09b84a11.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fd4050ad1bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jonathan Knapp <jaknapp8+aur@gmail.com>
+# URL: https://gitlab.com/thann/pingg
+# Upstream: https://gitlab.com/thann/pingg
+
+pkgname=pingg-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Ping latency graphical CLI.'
+arch=('any')
+url='http://gitlab.com/thann/pingg/'
+license=('UNLICENSE')
+depends=('nodejs')
+makedepends=('git' 'npm')
+provides=('pingg')
+conflicts=('pingg')
+source=("$pkgname::git+https://gitlab.com/thann/pingg.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/^v//;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ npm install -g --prefix "$pkgdir"/usr --user root --unsafe-perm
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ #HACK: npm is being lame and only installing a symlink =/
+ rm "$pkgdir/usr/lib/node_modules/pingg"
+ find * -exec install -D -m644 "{}" "$pkgdir/usr/lib/node_modules/pingg/{}" \;
+ find "$pkgdir/usr/lib/node_modules/pingg" -exec chmod +x "{}" \;
+ #HACK: remove references to $srcdir & $pkgdir (if you care)
+ # npm install -g removeNPMAbsolutePaths --prefix "$pkgdir"/usr
+ # "$pkgdir"/usr/bin/removeNPMAbsolutePaths "$pkgdir"/usr
+ # npm uninstall -g removeNPMAbsolutePaths --prefix "$pkgdir"/usr
+}