summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOleksandr Natalenko2016-11-04 18:45:45 +0100
committerOleksandr Natalenko2016-11-04 18:45:45 +0100
commit852a90a559ec87ddc2e3a391ea39de6e20b5ef3f (patch)
tree4c86ef2e21811a810d5dcda91f12ad2889fb3bbd /PKGBUILD
parentddc05db575bed2c9eb53b5e3fe8217dc41e45023 (diff)
downloadaur-852a90a559ec87ddc2e3a391ea39de6e20b5ef3f.tar.gz
update to v0.0.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 19 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 196464a32934..5653e05e6a18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
# Maintainer: Oleksandr Natalenko aka post-factum <oleksandr@natalenko.name>
pkgname=pingtcp
-pkgver=0.0.2
-pkgrel=2
+pkgver=0.0.4
+pkgrel=1
pkgdesc="Small utility to measure TCP handshake time (torify-friendly)"
-url="https://github.com/LanetNetwork/pingtcp"
+url="https://github.com/pfactum/${pkgname}"
arch=('i686' 'x86_64')
license=('GPLv3')
-depends=('glibc' 'gcc-libs')
-optdepends=('gperftools: for libtcmalloc' 'torsocks: for TOR support')
-makedepends=('cmake' 'git' 'make')
-source=(${pkgname}::git+https://github.com/LanetNetwork/pingtcp.git)
+depends=('glibc' 'gcc-libs' 'libunwind' 'gperftools')
+optdepends=('torsocks: for TOR support')
+makedepends=('gcc' 'cmake' 'make' 'libunwind' 'gperftools')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/pfactum/${pkgname}/archive/v${pkgver}.tar.gz)
-md5sums=('SKIP')
+sha256sums=('ba6f3eb2660f703394bd0d40271a71f4d03434c89d71ae92ba2a2dcb50fd6ea6')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
-build() {
- cd ${srcdir}/${pkgname}
- git submodule init
- git submodule update
mkdir -p build
- cd build
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
- # Detect CPUs count automatically
- CPUS_COUNT=$(nproc)
- echo "Compiling using $CPUS_COUNT thread(s)"
- make -j$CPUS_COUNT
+ make -j$(nproc)
}
package() {
- cd ${srcdir}/${pkgname}/build
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+
make install
}