summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephan Springer2023-02-06 19:49:37 +0100
committerStephan Springer2023-02-06 19:53:09 +0100
commita68f4b6482b2dc369b542c104ae3c3568d7afa0e (patch)
tree2fb9c0bdde0c3ec9a721c85e5a7efef7faa098b6 /PKGBUILD
parent45adfcd2f54fa1e17606084d888a22b71978c4b3 (diff)
downloadaur-pioneer.tar.gz
fix version string, don't use the build date
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 425133720c60..05fa590c2d87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=pioneer
pkgver=20230203
-pkgrel=1
+pkgrel=2
pkgdesc="A game of lonely space adventure"
arch=('x86_64')
url="https://github.com/pioneerspacesim/pioneer"
@@ -29,8 +29,11 @@ sha256sums=('80eea94e0f7e4d8e6a0c4629bdfb89201f82aae2f59ee7a1f7a487eeeccf27c7'
'dbb08eccb356c7b00122487b7a49df4948b82256c52b9cc36c5122a057c0635e')
prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 -i "$srcdir/fix_path_to_lua_h.patch" # https://github.com/pioneerspacesim/pioneer/issues/5525
+ cd "$pkgname-$pkgver"
+ # fix version string, don't use the build date
+ sed -i 's|PROJECT_VERSION "%Y%m%d"|PROJECT_VERSION "'$pkgver'"|' CMakeLists.txt
+ # https://github.com/pioneerspacesim/pioneer/issues/5525
+ patch -p1 -i "$srcdir/fix_path_to_lua_h.patch"
}
build()