summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2022-06-28 15:48:38 +0200
committerChristopher Arndt2022-06-28 15:48:38 +0200
commit4af92c526c73d9bfdda8a8f52c233cfcf8e05857 (patch)
tree65d02c2d1fb9f051c4e80665c424d48d55f3ff91 /PKGBUILD
parentfa569006c6b054166e2868a69eea8178a10e7987 (diff)
downloadaur-4af92c526c73d9bfdda8a8f52c233cfcf8e05857.tar.gz
New upstream version 6.7.0
Note: pip-sync is still broken when using python-pip 21.0 from Extra due to pip-tools using internal functions from pip, which are not part of its official API. python-pip 22.1.2, which should fix it, is currently in Testing.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 357aa83be216..0164d5fbb840 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,30 @@
# Contributor: Simon Conseil <contact+aur at saimon dot org>
pkgname=pip-tools
-pkgver=6.6.2
+pkgver=6.7.0
pkgrel=1
-pkgdesc="A set of tools to keep your pinned Python dependencies fresh."
-arch=('any')
-url="https://github.com/jazzband/pip-tools/"
-license=('BSD')
-depends=('python-click>=7' 'python-pep517' 'python-pip>=20.3' 'python-setuptools' 'python-wheel')
-makedepends=('python-setuptools-scm')
+pkgdesc='A set of tools to keep your pinned Python dependencies fresh'
+arch=(any)
+url='https://github.com/jazzband/pip-tools/'
+license=(BSD)
+depends=('python-click>=7' python-build 'python-pip>=21' python-setuptools python-wheel)
+makedepends=(python-setuptools-scm)
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('f638503a9f77d98d9a7d72584b1508d3f82ed019b8fab24f4e5ad078c1b8c95e')
+sha256sums=('0aeedc28c0316a30c561893a1f41c3611b46ac536bc271082ffdbdbd1d26924c')
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
-
+ cd $pkgname-$pkgver
# extra/python-pip is still at version 21.0 due to packaging issues
sed -i -e 's/pip >= .*/pip/' setup.cfg
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
+ cd $pkgname-$pkgver
python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
+ cd $pkgname-$pkgver
python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
# license
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"