summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2015-12-01 22:26:21 +0100
committerChristopher Arndt2015-12-01 22:26:21 +0100
commitff41b1f3baa18bad23b3f8e56a59e82131f49a71 (patch)
treeae99698319903f4d5882332debad06399b64b714 /PKGBUILD
parent14b0da120cfbf4c61bf7882462020be621df709c (diff)
downloadaur-ff41b1f3baa18bad23b3f8e56a59e82131f49a71.tar.gz
Adopted package: new upstream version 1.2.0; added 'python-pip' and 'python-first' to and removed python from dependencies; added LICENSE.txt
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbab6c45115d..a9cbfe5ebd76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
-# Maintainer: Simon Conseil <contact+aur at saimon dot org>
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Contributor: Simon Conseil <contact+aur at saimon dot org>
+
pkgname=pip-tools
-pkgver=1.1.4
+pkgver=1.2.0
pkgrel=1
pkgdesc="A set of tools to keep your pinned Python dependencies fresh."
arch=('any')
url="https://github.com/nvie/pip-tools"
license=('BSD')
-depends=('python' 'python-click' 'python-six')
-source=("http://pypi.python.org/packages/source/p/pip-tools/$pkgname-$pkgver.tar.gz")
-md5sums=('d4c8d2d53f565768147174e39c085ebd')
+depends=('python-click' 'python-six')
+source=("http://pypi.python.org/packages/source/p/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ LICENSE.txt)
+md5sums=('f1771bee558b5abd8b206fdeb1e51d69'
+ 'b542fe20de254615b3ab48020bc73441')
package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 "${srcdir}/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname"
}
# vim:set ts=2 sw=2 et: