summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwenLiangcan2023-08-14 21:08:27 +0800
committerwenLiangcan2023-08-14 21:11:54 +0800
commita5c4b6149481e335800880a80d5a0d11ad5d803e (patch)
tree07727ef06d3b3f996c30dfebc81d425d050f023b /PKGBUILD
parent51e2422656e7b9da65fb55024e7d59d2bfe72453 (diff)
downloadaur-a5c4b6149481e335800880a80d5a0d11ad5d803e.tar.gz
Remove Python 2 package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 6 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c30182bb60b1..a6951b98d706 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,23 @@
-pkgbase='pip2pkgbuild'
-pkgname=('pip2pkgbuild' 'python2-pip2pkgbuild')
+pkgname='pip2pkgbuild'
_module='pip2pkgbuild'
pkgver='0.3.3'
-pkgrel=1
+pkgrel=2
pkgdesc="Generate PKGBUILD file for a Python module from PyPI"
url="https://github.com/wenLiangcan/pip2pkgbuild"
-depends=()
-makedepends=('python-setuptools' 'python2-setuptools')
+depends=('python')
+makedepends=('python-setuptools')
license=('MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/${_module/-/_}-$pkgver.tar.gz")
sha256sums=('90172b48a10a2e416a7844e38892fa9b592af1cabc766938804f91fe62be8fc2')
-prepare() {
- cp -a "${srcdir}/${_module}-${pkgver}"{,-python2}
-}
-
build() {
cd "${srcdir}/${_module}-${pkgver}"
python setup.py build
-
- cd "${srcdir}/${_module}-${pkgver}-python2"
- python2 setup.py build
}
-package_pip2pkgbuild() {
- depends+=('python')
+package() {
+ depends+=()
cd "${srcdir}/${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
-
-package_python2-pip2pkgbuild() {
- depends+=('python2')
- cd "${srcdir}/${_module}-${pkgver}-python2"
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- mv "${pkgdir}/usr/bin/pip2pkgbuild"{,2}
-}