summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwenLiangcan2023-11-27 22:14:19 +0800
committerwenLiangcan2023-11-27 22:14:19 +0800
commitdf9c826556149de6f56a9618655ae507a465a6ba (patch)
treeae0265356308544d98372757828d60beac832ccd /PKGBUILD
parentfc745507385d21619aac9daee51f0adce3c2fe7d (diff)
downloadaur-df9c826556149de6f56a9618655ae507a465a6ba.tar.gz
pip2pkgbuild 0.3.5-1.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b46e9e175fe..1e085c495043 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
pkgname='pip2pkgbuild'
_module='pip2pkgbuild'
-pkgver='0.3.4'
+_src_folder='pip2pkgbuild-0.3.5'
+pkgver='0.3.5'
pkgrel=1
pkgdesc="Generate PKGBUILD file for a Python module from PyPI"
url="https://github.com/wenLiangcan/pip2pkgbuild"
@@ -8,16 +9,16 @@ depends=('python')
makedepends=('python-build' 'python-installer')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/${_module/-/_}-$pkgver.tar.gz")
-sha256sums=('8ba9de892d30259fe53073bb285f1562926e76d6d7866494f3160400ec2ebe52')
+source=("https://files.pythonhosted.org/packages/a0/ad/ca17f7b6704986da1df26770349b55369a789effa781d96f8992c4a83bd3/pip2pkgbuild-0.3.5.tar.gz")
+sha256sums=('14f5e457dcf1bef0764374c753a535fbed8c0c5c950edb2874c1b438e6fc3773')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_src_folder}"
python -m build --wheel --no-isolation
}
package() {
depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_src_folder}"
python -m installer --destdir="${pkgdir}" dist/*.whl
}