summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwenLiangcan2023-09-14 20:47:34 +0800
committerwenLiangcan2023-09-14 20:47:34 +0800
commitfc745507385d21619aac9daee51f0adce3c2fe7d (patch)
treec91cb98cb027d3116ada45eaef7daa0cedfbb3a9 /PKGBUILD
parenta5c4b6149481e335800880a80d5a0d11ad5d803e (diff)
downloadaur-fc745507385d21619aac9daee51f0adce3c2fe7d.tar.gz
0.3.4-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6951b98d706..0b46e9e175fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
pkgname='pip2pkgbuild'
_module='pip2pkgbuild'
-pkgver='0.3.3'
-pkgrel=2
+pkgver='0.3.4'
+pkgrel=1
pkgdesc="Generate PKGBUILD file for a Python module from PyPI"
url="https://github.com/wenLiangcan/pip2pkgbuild"
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer')
license=('MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/${_module/-/_}-$pkgver.tar.gz")
-sha256sums=('90172b48a10a2e416a7844e38892fa9b592af1cabc766938804f91fe62be8fc2')
+sha256sums=('8ba9de892d30259fe53073bb285f1562926e76d6d7866494f3160400ec2ebe52')
build() {
cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
depends+=()
cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}