summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFerdinand Bachmann2021-12-30 01:41:30 +0100
committerFerdinand Bachmann2021-12-30 01:41:30 +0100
commitd27c3c5b9e656138e3eb4d4c30583e9451266622 (patch)
treec1615028cab4a99f7152d2832374f76c8e90823b /PKGBUILD
downloadaur-d27c3c5b9e656138e3eb4d4c30583e9451266622.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2bdac1c6755
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Ferdinand B <theferdi265@gmail.com>
+
+pkgname=pipectl
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="a simple named pipe management utility"
+url="https://github.com/Ferdi265/pipectl"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=()
+makedepends=('git' 'cmake')
+source=(
+ "pipectl-$pkgver.tar.gz::https://github.com/Ferdi265/pipectl/archive/refs/tags/v$pkgver.tar.gz"
+)
+sha256sums=('SKIP')
+
+build() {
+ cmake -B build -S "$srcdir/pipectl-$pkgver" -DCMAKE_INSTALL_PREFIX=/usr
+ make -C build
+}
+
+package() {
+ make -C build DESTDIR="$pkgdir" install
+}