summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHuang-Huang Bao2021-05-13 08:27:38 +0800
committerHuang-Huang Bao2021-05-13 08:27:38 +0800
commitadc6fefd4e1699e9d601599d64d2a8fce6752e81 (patch)
treeae00ad23111a681ff12b751cf7e346957b97340b /PKGBUILD
parentdeed322e6ae6898b333ad45a55be96e0ceeebd0f (diff)
downloadaur-adc6fefd4e1699e9d601599d64d2a8fce6752e81.tar.gz
Add libpulse dep to build module-pulse-tunner
Also change license to (MIT LGPL), see https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1174. The source code of PW is licensed under MIT but alsa plugin and alsa card profiles are licensed undere LGPL, we might want to split up packages by license later, but let see how extra/pipewire move first.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0f19d7dcb51..931eed8c3bb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,17 @@ pkgname=(pipewire-full-git pipewire-full-docs-git pipewire-full-alsa-git
gst-plugin-pipewire-full-git
pipewire-full-jack-client-git
pipewire-full-vulkan-git pipewire-full-ffmpeg-git)
-pkgver=0.3.25.r47.g99eeec58
+pkgver=0.3.27.r82.ga6c0e35b
pkgrel=1
pkgdesc="Low-latency audio/video router and processor"
url="https://pipewire.org"
-license=(MIT)
+license=(MIT LGPL)
arch=(x86_64)
-makedepends=(git meson doxygen graphviz xmltoman jack2
- alsa-lib gst-plugins-base-libs sbc rtkit vulkan-icd-loader dbus
- sdl2 ncurses libsndfile bluez-libs vulkan-headers libldac
- libopenaptx libfdk-aac ffmpeg)
+makedepends=(git meson doxygen graphviz xmltoman
+ ncurses libsndfile alsa-lib dbus rtkit
+ libpulse sdl2 gst-plugins-base-libs
+ bluez-libs sbc libldac libopenaptx libfdk-aac
+ jack2 vulkan-headers vulkan-icd-loader ffmpeg)
source=("git+https://gitlab.freedesktop.org/pipewire/pipewire.git")
sha256sums=('SKIP')
@@ -62,8 +63,9 @@ _ver=${pkgver:0:3}
package_pipewire-full-git() {
depends=(rtkit libdbus-1.so libncursesw.so libsndfile.so
- libudev.so libasound.so libsystemd.so libbluetooth.so
- libsbc.so libldacBT_enc.so libopenaptx.so libfdk-aac.so)
+ libudev.so libasound.so libsystemd.so libpulse.so
+ libbluetooth.so libsbc.so libldacBT_enc.so
+ libopenaptx.so libfdk-aac.so)
optdepends=('pipewire-full-docs-git: Documentation'
'pipewire-full-alsa-git: ALSA configuration'
'pipewire-full-jack-git: JACK support'