summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-07-05 08:50:17 -0600
committerMark Wagie2022-07-05 08:50:17 -0600
commit5381328ec7df1907f84af27299944a6cb9caba0d (patch)
treeab4d921114269f915aa6b0aa85247f751363ce4d /PKGBUILD
parent53e91d6857174a4283534b9a88152f932a0d4f4c (diff)
downloadaur-5381328ec7df1907f84af27299944a6cb9caba0d.tar.gz
0.8.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 149f8155e5d9..7166fa6e2972 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=pipgrip
-pkgver=0.8.2
+pkgver=0.8.3
pkgrel=1
pkgdesc="Lightweight pip dependency resolver with deptree preview functionality based on the PubGrub algorithm"
arch=('any')
@@ -10,13 +10,14 @@ depends=('python-anytree' 'python-click' 'python-pip' 'python-packaging' 'python
'python-setuptools' 'python-wheel')
makedepends=('python-build' 'python-installer' 'python-setuptools-scm')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('e8ae2009fca122dc4410b28b31505eb447dffc600b74347e75d911543eb65e88')
+sha256sums=('ed0f7854a9df677a713d74024c9fe50b91dba57543af6d51ca032f1e36b40e12')
prepare() {
cd "$pkgname-$pkgver"
- # Relax pkginfo requirement
+ # Relax requirements
sed -i 's/pkginfo>=1.4.2,<1.8/pkginfo>=1.4.2/g' requirements/prod.txt
+ sed -i 's/setuptools_scm<7/setuptools_scm/g' setup.py
}
build() {