summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2024-03-27 10:54:52 -0600
committerMark Wagie2024-03-27 10:54:52 -0600
commitb552696b3879ae56787ae691ea46f17eee543e20 (patch)
tree260b687939f54d981619f50a2b456f9dee433ab7 /PKGBUILD
parent0e60a4e6a582aa2a6f017e1121b5f137b2a9d638 (diff)
downloadaur-b552696b3879ae56787ae691ea46f17eee543e20.tar.gz
use GitHub tarball
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0e61284cf84..c149dbef510a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=pipgrip
pkgver=0.10.13
-pkgrel=1
+pkgrel=2
pkgdesc="Lightweight pip dependency resolver with deptree preview functionality based on the PubGrub algorithm"
arch=('any')
url="https://github.com/ddelange/pipgrip"
@@ -19,8 +19,8 @@ makedepends=(
'python-installer'
'python-setuptools-scm'
)
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('f481ef054c37036d334ca6f4b8608c1ca8a113e02e011276b540f1558dc394ba')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('5771986f78898265845b2d920b0689f80e45c62c1fe4c5b3d2a3d47f23f7a46d')
prepare() {
cd "$pkgname-$pkgver"
@@ -31,6 +31,7 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
python -m build --wheel --no-isolation
}