summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-11-21 11:22:38 -0700
committerMark Wagie2020-11-21 11:22:38 -0700
commitd911bae9f8a2b586584a89269a504a7a4ba1dd99 (patch)
tree3d50cfc07fb41d58657b4eb624c24b7a5f9915f9 /PKGBUILD
downloadaur-d911bae9f8a2b586584a89269a504a7a4ba1dd99.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a5237ec6dea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=pipgrip
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="Lightweight pip dependency resolver with deptree preview functionality based on the PubGrub algorithm"
+arch=('any')
+url="https://github.com/ddelange/pipgrip"
+license=('BSD')
+depends=('python-anytree' 'python-click' 'python-packaging' 'python-pkginfo'
+ 'python-setuptools' 'python-wheel' 'python-pip')
+source=("https://pypi.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('b2dcd453e509185fba95ba36c14955ed27c81f5ab8f620818a21b8d7c5909737')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname"
+}