summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeon Kowarschick2020-05-11 12:06:09 +0200
committerLeon Kowarschick2020-05-11 12:06:09 +0200
commit5a09237095d976a500f20f7be527beee2f164b03 (patch)
tree10c3322f345de3b1e38986fde428f213a1a5888a /PKGBUILD
downloadaur-5a09237095d976a500f20f7be527beee2f164b03.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05371ffa1dd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Leon Kowarschick <lkowarschick at gmail dot com>
+pkgname=pipr-bin
+pkgver=0.0.11
+pkgrel=1
+makedepends=()
+#depends=('gcc-libs')
+depends=()
+optdepends=('bubblewrap: run commands in isolation. STRONGLY RECOMMENDED!')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="A commandline-utility to interactively build complex shell pipelines"
+license=('MIT')
+source=('pipr::https://gitlab.com/Elkowar/pipr/uploads/9a4eb309170edb8880d550187e87a8a9/pipr'
+ 'pipr-git::git+https://gitlab.com/Elkowar/pipr.git')
+url="https://gitlab.com/Elkowar/pipr"
+md5sums=('SKIP'
+ 'SKIP')
+
+
+package() {
+ cd "$srcdir"
+ install -Dm 755 pipr -t "${pkgdir}/usr/bin"
+ cd "$srcdir/pipr-git"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}