summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulien Seguinot2019-01-22 12:51:47 +0900
committerJulien Seguinot2019-01-22 12:51:47 +0900
commit6949e316fce3181ab8dd9843990cd3283db4de4e (patch)
treeffa60d8c07f71b6609c6de0e643854ab7c5b2a0d /PKGBUILD
downloadaur-6949e316fce3181ab8dd9843990cd3283db4de4e.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0da58ffe73f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Julien Seguinot <seguinot@vaw.baug.ethz.ch>
+
+pkgname=pism
+pkgver=1.1
+pkgrel=1
+pkgdesc="Parallel Ice Sheet Model (PISM)"
+arch=('i686' 'x86_64')
+url="http://www.pism-docs.org/"
+license=('GPL')
+depends=('fftw>=3.1' 'gsl>=1.15' 'netcdf' 'openmpi' 'petsc>=3.5' 'proj' 'udunits')
+makedepends=('gcc' 'cmake>=3.1')
+optdepends=() # FIXME proj is an optional dependence
+source=("https://github.com/pism/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('c8caa9e70ca44b179da0a25d0e65832b')
+
+build() {
+ mkdir -p "$pkgname-$pkgver/build"
+ cd "$pkgname-$pkgver/build"
+ CC=mpicc CXX=mpicxx PETSC_DIR=/opt/petsc/linux-c-opt PISM_INSTALL_PREFIX=/usr cmake .. -DPism_USE_PROJ4=Yes
+ make -j 4
+}
+
+package() {
+ cd "$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+}