summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2021-10-11 16:57:37 +0200
committerMartchus2021-10-11 16:57:37 +0200
commita9aa65d4543695f6385104757298474dfa7735fb (patch)
tree0442edf0bd2425911a50aa473cd9910a8f8cb004 /PKGBUILD
parentb9c4a487a1e27434f6924687a195978d40eaa4ff (diff)
downloadaur-pistache-git.tar.gz
Fix packaging errors and dependencies
* Fix packaging errors by following https://wiki.archlinux.org/title/Meson_package_guidelines * Add missing dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d453a210b6c6..1d4358a7b637 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@ pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Modern and elegant HTTP and REST framework for C++'
license=('APACHE')
-depends=()
-makedepends=('meson' 'git')
+depends=('openssl')
+makedepends=('rapidjson' 'meson' 'git')
checkdepends=('gtest')
provides=("${_name}")
conflicts=("${_name}")
@@ -28,7 +28,7 @@ pkgver() {
build() {
cd "${srcdir}/${_name}"
- meson setup build \
+ arch-meson build \
--buildtype=release \
-DPISTACHE_USE_SSL=true \
-DPISTACHE_BUILD_EXAMPLES=true \
@@ -44,5 +44,5 @@ check() {
package() {
cd "${srcdir}/${_name}"
- meson install -C build
+ DESTDIR="$pkgdir" meson install -C build
}