summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2017-07-03 22:47:23 +0200
committerMartchus2017-07-03 22:48:25 +0200
commitaf282b9276d83cfd9a0705e27eb840d6dc8ba058 (patch)
tree77e113c80beb6bf637b9508437ddd744af398866 /PKGBUILD
parent13f0799ec3ceb45e07cda4a79417d7272cf576c2 (diff)
downloadaur-af282b9276d83cfd9a0705e27eb840d6dc8ba058.tar.gz
Update to 189.9827cda
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a52e5ce87028..3291a913a2af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=pistache-git
_name=${pkgname%-git}
-pkgver=176.8604968
+pkgver=189.9827cda
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Modern and elegant HTTP and REST framework for C++'
@@ -16,11 +16,9 @@ provides=("${_name}")
conflicts=("${_name}")
url="https://github.com/oktal/${_name}"
source=("${_name}::git://github.com/oktal/${_name}.git"
- '0001-Call-library-target-pistache-to-avoid-conflict-with-.patch'
- '0002-Export-targets.patch')
+ '0001-Export-targets.patch')
sha256sums=('SKIP'
- '28383926baaa5f8b57f3513d21cafe8997dc779cff8170676904c39e20e7a71e'
- '4e2a5cc2bd0c1c85d9bbff03325af03fb1742aefed7dbada231e76b4ad2d20e7')
+ '68140dc3747b36e3287913cdb4e4ae1a2cc85d69e28560dee3937f6143e0cc5f')
pkgver() {
cd "${srcdir}/${_name}"
@@ -30,12 +28,15 @@ pkgver() {
prepare() {
cd "${srcdir}/${_name}"
- patch -p1 -i "${srcdir}/0001-Call-library-target-pistache-to-avoid-conflict-with-.patch"
- patch -p1 -i "${srcdir}/0002-Export-targets.patch"
+ patch -p1 -i "${srcdir}/0001-Export-targets.patch"
}
build() {
cd "${srcdir}/${_name}"
+
+ # since this is only a small lib and ABI seems very unstable at this point
+ # it should be ok to build it only as a static lib for now
+
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr"