summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHenry-Joseph Audéoud2021-09-16 15:12:14 +0200
committerHenry-Joseph Audéoud2021-10-18 11:08:26 +0200
commit246f3f2a2df03fabca57519f35e183657c0ebae1 (patch)
tree96252eeff83cf437015669c3f4b5e283638afb66 /PKGBUILD
parentdfcece75a97e8e175853a2766ead655c47f5ad6e (diff)
downloadaur-246f3f2a2df03fabca57519f35e183657c0ebae1.tar.gz
Drop file permission tweaking at installation time
Post-install permissions tweaking may lead to different permission between installed files and package files. It's better to keep that sync'ed. Keeping the `piwigo.perm.sh` script for now, for manual usage (even if its necessity certainly comes from a wrong installation method).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 13 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d0cae875cfa..f82b78e130f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=piwigo
pkgver=11.5.0
-pkgrel=1
-pkgdesc="Piwigo is a photo gallery software for the web that comes with powerful features to publish and manage your collection of pictures."
+pkgrel=2
+pkgdesc='Photo gallery software for the web'
arch=(any)
url="https://piwigo.org/"
license=("GPL")
@@ -9,16 +9,13 @@ optdepends=('php-apache: to use the Apache web server')
depends=("php" "php-gd" "mariadb")
makedepends=("unzip")
backup=("etc/webapps/piwigo/apache.conf")
-install=piwigo.install
options=(emptydirs)
-
source=('piwigo.zip::https://piwigo.org/download/dlcounter.php?code=latest'
'apache.conf'
'piwigo.perm.sh')
-md5sums=('93dcdb04fa929b02e13cdb2eb6de3caa'
- '5d1da01ee31fa1ad7a2b7e11766ec1f7'
- 'a855fa62a5ae3595f3361ae42c3cdf2f')
-
+sha256sums=('bfecdd743c62cdb4e1936662178d019af264ea763d26c8c832da836fbe09652d'
+ '5810668c0f9e7066a2f63e2c6b6fb5d13b7caa96fed16c882f6da2e7a6766219'
+ '0e6d4af6552f4eead62825999eee115152cf5f884f2c65b759379ac5b15d36f7')
pkgver() {
# curl -Is https://github.com/Piwigo/Piwigo/releases/latest | awk -F'/' '/^Location/ {print $NF}' | sed 's/[^[:print:]]//'
@@ -28,24 +25,14 @@ pkgver() {
package() {
- ### install piwigo
- mkdir -p "${pkgdir}/usr/share/webapps"
- cp -a piwigo "${pkgdir}/usr/share/webapps/."
+ install_path="${pkgdir}/usr/share/webapps/piwigo"
+
+ cd "${srcdir}"
- ### default perm
- find "${pkgdir}/usr/share/webapps/piwigo/" -type f -print0 | xargs -0 chmod 0640
- find "${pkgdir}/usr/share/webapps/piwigo/" -type d -print0 | xargs -0 chmod 0750
- install -D -m755 "${srcdir}/piwigo.perm.sh" "${pkgdir}/usr/bin/set-piwigo-perm"
+ # Install main files
+ install -d "${install_path}"
+ cp -a piwigo/* "${install_path}/"
- ### apache conf (optionnal)
- mkdir -p "${pkgdir}/etc/webapps/piwigo"
- install -m644 "${srcdir}/apache.conf" "${pkgdir}/etc/webapps/piwigo/apache.conf"
- ## add 2 patch from pull request
- ## cd ${pkgdir}/usr/share/webapps/piwigo/
- ## curl https://github.com/Piwigo/Piwigo/commit/c6ed0b5838b6dbcbdcc5d9cddf2c66362cea4591.patch --output pull1.patch
- ## curl https://github.com/Piwigo/Piwigo/commit/f1d1b55d82e9f2d77c5b54422bced31f44370ce0.patch --output pull2.patch
- ## curl https://github.com/Piwigo/Piwigo/commit/53e52711236f3657d2b447726459f29fc1a1bb25.patch --output pull3.patch
- ## patch -p1 < pull1.patch
- ## patch -p1 < pull2.patch
- ## patch -p1 < pull3.patch
+ # Install apache & nginx conf'
+ install -D -m644 apache.conf "${pkgdir}/etc/webapps/piwigo/apache.conf"
}