summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHenry-Joseph Audéoud2021-09-16 15:27:10 +0200
committerHenry-Joseph Audéoud2021-10-18 11:15:51 +0200
commita45280364e018365ecef3770d0e13281dd69deb6 (patch)
treefe355bc6af140d5ed7c6382297f73607848bd0fd /PKGBUILD
parentf0c2c46002a7ce1b314d17434c800bb9bf7f6e51 (diff)
downloadaur-a45280364e018365ecef3770d0e13281dd69deb6.tar.gz
Add support for nginx web server
nginx is only the web server frontend. PHP-FPM is used to run the FastCGI end. Piwigo only runs on PHP7, so use this version in dependencies.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 23 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7267ae263f95..5d80217b310b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,40 @@
+# Maintainer: Fanch
+# Contributor: Henry-Joseph Audéoud <h.audeoud@gmail.com>
+
pkgname=piwigo
pkgver=11.5.0
-pkgrel=4
+pkgrel=5
pkgdesc='Photo gallery software for the web'
arch=(any)
url="https://piwigo.org/"
license=("GPL")
-depends=('php' 'mariadb' 'php-apache')
-optdepends=('php-gd: graphic library (one graphic library is required)'
+depends=('php7' 'mariadb')
+optdepends=('php7-gd: graphic library (one graphic library is required)'
'imagemagick: graphic library (one graphic library is required)'
+ 'php7-apache: Apache Web Server (one web server is required)'
+ 'nginx: nginx Web Server (one web server is required)'
+ 'php7-fpm: FastCGI, required with nginx Web Server'
'exiftool: Write Metadata plugin or any other plugin dealing with EXIF/IPTC metadata'
'ffmpeg: VideoJS plugin to create video poster'
'jpegtran: RotateImage plugin to rotate images with no compression'
'pdftoppm: generate poster from PDF files (instead of ImageMagick)')
makedepends=("unzip")
-backup=("etc/webapps/piwigo/apache.conf")
+backup=('etc/webapps/piwigo/apache.conf'
+ 'etc/nginx/sites-available/piwigo.conf'
+ 'etc/php7/php-fpm.d/piwigo.conf')
options=(emptydirs)
source=('piwigo.zip::https://piwigo.org/download/dlcounter.php?code=latest'
'apache.conf'
- 'piwigo.perm.sh')
+ 'piwigo.perm.sh'
+ 'nginx.conf'
+ 'php-fpm7.conf'
+ 'php-fpm7.service.conf')
sha256sums=('bfecdd743c62cdb4e1936662178d019af264ea763d26c8c832da836fbe09652d'
'64435b2f5fe29ab6201e00a755bff5dbe77bc4450559a2668a21e750ce13f8be'
- '0e6d4af6552f4eead62825999eee115152cf5f884f2c65b759379ac5b15d36f7')
+ '0e6d4af6552f4eead62825999eee115152cf5f884f2c65b759379ac5b15d36f7'
+ 'c27d837157cc6b189f62e36b43532efdf9881f5db8059ba5a430be2ad9154937'
+ 'af481516383faae67bb02d604dbe07778e352aa01fc548e0cd641a902fddbfb7'
+ '4fd0561c64ab8a1b166e69b4ce9985f343bcd351d33fc055604edf94f11317f4')
package() {
install_path="${pkgdir}/usr/share/webapps/piwigo"
@@ -44,6 +58,9 @@ package() {
# Install apache & nginx conf'
install -D -m644 apache.conf "${pkgdir}/etc/webapps/piwigo/apache.conf"
+ install -D -m644 nginx.conf "${pkgdir}/etc/nginx/sites-available/piwigo.conf"
+ install -D -m644 php-fpm7.conf "${pkgdir}/etc/php7/php-fpm.d/piwigo.conf"
+ install -D -m644 php-fpm7.service.conf "${pkgdir}/usr/lib/systemd/system/php-fpm7.service.d/piwigo.conf"
# database.inc.php should be writeable in ${install_path}/local/config,
# with no way to select the path of this file. Make that directory