summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHenry-Joseph Audéoud2021-12-03 17:36:26 +0100
committerHenry-Joseph Audéoud2021-12-03 17:45:55 +0100
commitc8404bb50dba4b6d2423b329aae5ee1a6270cac9 (patch)
treebc4724bd7db7cedb243bdda803411a10bcc97836 /PKGBUILD
parent09b8692316918093616f6c76155deac91181e8d2 (diff)
downloadaur-c8404bb50dba4b6d2423b329aae5ee1a6270cac9.tar.gz
upgpkg: piwigo 12.0.0-1
upstream release - Use of PHP8 instead of PHP7. - Install upstream's documentation - Listen on port 80 in the nginx conf' to redirect HTTP clients towards port 443
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 23 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c763aa57f47..2064ae3b0569 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Fanch
-# Contributor: Henry-Joseph Audéoud <h.audeoud@gmail.com>
+# Co-maintainer: Henry-Joseph Audéoud <h.audeoud@gmail.com>
pkgname=piwigo
-pkgver=11.5.0
-pkgrel=6
+pkgver=12.0.0
+pkgrel=1
pkgdesc='Photo gallery software for the web'
arch=(any)
url="https://piwigo.org/"
license=("GPL")
-depends=('php7' 'mariadb')
-optdepends=('php7-gd: graphic library (one graphic library is required)'
+depends=('php' 'mariadb')
+optdepends=('php-gd: graphic library (one graphic library is required)'
'imagemagick: graphic library (one graphic library is required)'
- 'php7-apache: Apache Web Server (one web server is required)'
+ 'php-apache: Apache Web Server (one web server is required)'
'nginx: nginx Web Server (one web server is required)'
- 'php7-fpm: FastCGI, required with nginx Web Server'
+ 'php-fpm: FastCGI, required with nginx Web Server'
'exiftool: Write Metadata plugin or any other plugin dealing with EXIF/IPTC metadata'
'ffmpeg: VideoJS plugin to create video poster'
'jpegtran: RotateImage plugin to rotate images with no compression'
@@ -21,31 +21,33 @@ optdepends=('php7-gd: graphic library (one graphic library is required)'
makedepends=("unzip")
backup=('etc/webapps/piwigo/apache.conf'
'etc/nginx/sites-available/piwigo.conf'
- 'etc/php7/php-fpm.d/piwigo.conf')
+ 'etc/php/php-fpm.d/piwigo.conf')
options=(emptydirs)
-source=("piwigo.zip::https://piwigo.org/download/dlcounter.php?code=${pkgver}"
+source=("${pkgname}-${pkgver}.zip::https://piwigo.org/download/dlcounter.php?code=${pkgver}"
'apache.conf'
'piwigo.perm.sh'
'nginx.conf'
- 'php-fpm7.conf'
- 'php-fpm7.service.conf')
-sha256sums=('bfecdd743c62cdb4e1936662178d019af264ea763d26c8c832da836fbe09652d'
+ 'php-fpm.conf'
+ 'php-fpm.service.conf')
+sha256sums=('cb711819cfcc931e79f975cef1fc12f7d1289d2d260455af1aac91419858e68f'
'64435b2f5fe29ab6201e00a755bff5dbe77bc4450559a2668a21e750ce13f8be'
'0e6d4af6552f4eead62825999eee115152cf5f884f2c65b759379ac5b15d36f7'
- 'c27d837157cc6b189f62e36b43532efdf9881f5db8059ba5a430be2ad9154937'
- 'af481516383faae67bb02d604dbe07778e352aa01fc548e0cd641a902fddbfb7'
- '4fd0561c64ab8a1b166e69b4ce9985f343bcd351d33fc055604edf94f11317f4')
+ '13db3e357bd30cab3ba9eb460e76ac9009cf974606ea55981d30c326db6db366'
+ '8c0f750df745cfcb23a6e61993683a55c0b8ea8b0e0805c5b1bf72312d653b63'
+ 'ca2387a701ec88b1c995f2dfc35832c3d3aea6f54741da85cf246fb64bc8d2bb')
package() {
install_path="${pkgdir}/usr/share/webapps/piwigo"
var_path="${pkgdir}/var/lib/piwigo"
http_user=33
- cd "${srcdir}"
-
# Install main files
install -d "${install_path}"
- cp -a piwigo/* "${install_path}/"
+ cp -a ${pkgname}/* "${install_path}/"
+
+ # Install doc
+ install -d "${pkgdir}/usr/share/doc/piwigo/"
+ mv -t "${pkgdir}/usr/share/doc/piwigo/" "${install_path}/docs"/*
# Variable data directories. Should be in /var, but no way to change it in
# piwigo configuration (Bug Report?). So use symbolic links to allow that.
@@ -58,9 +60,9 @@ package() {
# Install apache & nginx conf'
install -D -m644 apache.conf "${pkgdir}/etc/webapps/piwigo/apache.conf"
- install -D -m644 nginx.conf "${pkgdir}/etc/nginx/sites-available/piwigo.conf"
- install -D -m644 php-fpm7.conf "${pkgdir}/etc/php7/php-fpm.d/piwigo.conf"
- install -D -m644 php-fpm7.service.conf "${pkgdir}/usr/lib/systemd/system/php-fpm7.service.d/piwigo.conf"
+ install -D -m644 nginx.conf "${pkgdir}/etc/nginx/sites-available/piwigo.conf.example"
+ install -D -m644 php-fpm.conf "${pkgdir}/etc/php/php-fpm.d/piwigo.conf"
+ install -D -m644 php-fpm.service.conf "${pkgdir}/usr/lib/systemd/system/php-fpm.service.d/piwigo.conf"
# database.inc.php should be writeable in ${install_path}/local/config,
# with no way to select the path of this file. Make that directory