summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornate2024-01-20 10:12:10 -0600
committernate2024-01-20 10:15:14 -0600
commitcbfb16899c1819f63cbc0b94adbfd04d17427233 (patch)
treec23ae633a2be0779e1ea517f17eb11a2cb0c31ac /PKGBUILD
parent7ef5e3957a2890b30b9a4cadefad695a20a56786 (diff)
downloadaur-cbfb16899c1819f63cbc0b94adbfd04d17427233.tar.gz
patch pix for build with jxl 0.9.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ce88f488840..6d95c091dd9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pix
pkgver=3.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Image viewer and browser based on gthumb. X-Apps Project."
arch=('i686' 'x86_64' 'armv7h')
license=('GPL')
@@ -39,9 +39,15 @@ provides=($pkgname)
conflicts=('pix-git')
url='https://github.com/linuxmint/pix'
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/linuxmint/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('450fed1003f786b7f904c65662115cdf')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/linuxmint/${pkgname}/archive/${pkgver}.tar.gz"
+'0001-jxl-added-support-for-version-0.9.0.patch'
+)
+md5sums=('450fed1003f786b7f904c65662115cdf' '9e81ebbe9dbd6638b178189c1a5ab51b')
+prepare() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ patch --forward --strip=1 --input="${srcdir}"/0001-jxl-added-support-for-version-0.9.0.patch
+}
build() {
mkdir -p "${srcdir}"/${pkgname}-${pkgver}/build