summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTércio Martins2021-02-08 22:04:42 -0300
committerTércio Martins2021-02-08 22:04:42 -0300
commitaba3a3233c28862d1c3d3f3e27c92e4ebb05898c (patch)
tree57da1fc508cdfac9d3e94ee198e14620762efab7 /PKGBUILD
parent33de865ff77487cb4e85b13a60c815d6462d54c0 (diff)
downloadaur-aba3a3233c28862d1c3d3f3e27c92e4ebb05898c.tar.gz
Added make dependency (xorg-server-xvfb) for Godot not to display the window during build (suggestion of @xyproto)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46dae858ef11..658be2f83698 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@ arch=('i686' 'pentium4' 'x86_64')
url="https://orama-interactive.itch.io/pixelorama"
_url="https://github.com/Orama-Interactive/Pixelorama"
license=('MIT')
-depends=('alsa-lib' 'hicolor-icon-theme' 'libglvnd' 'libpulse' 'libxcursor' 'libxinerama' 'libxrandr')
-makedepends=('curl' 'godot' 'unzip')
+depends=('alsa-lib' 'hicolor-icon-theme' 'libglvnd' 'libpulse' 'libxcursor' 'libxi' 'libxinerama' 'libxrandr')
+makedepends=('curl' 'godot' 'unzip' 'xorg-server-xvfb')
provides=('pixelorama')
conflicts=('pixelorama-bin' 'pixelorama-git')
source=("${pkgname^}-${pkgver}.tar.gz::${_url}/archive/v${pkgver}.tar.gz")
@@ -61,7 +61,7 @@ prepare() {
build() {
cd "${srcdir}/${pkgname^}-${pkgver}"
mkdir -p build
- godot --export "Linux/X11 $(getconf LONG_BIT)-bit" --path . project.godot build/${pkgname}
+ xvfb-run godot --export "Linux/X11 $(getconf LONG_BIT)-bit" --path . project.godot build/${pkgname}
}
package() {