summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTércio Martins2020-10-17 00:21:19 -0300
committerTércio Martins2020-10-17 00:21:19 -0300
commiteb414c93abd73207ce4b1b027e06501ecc04dd02 (patch)
tree60f26a2ea087a8cd4a3cfe9649877dd838388a6b /PKGBUILD
parente6fcb265990e4208656704b3e264085295790dd5 (diff)
downloadaur-eb414c93abd73207ce4b1b027e06501ecc04dd02.tar.gz
Update to version 0.8.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3d566af2ae0..ac397e06421a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
_pkgname=Pixelorama
pkgname=pixelorama
-pkgver=0.8
+pkgver=0.8.1
pkgrel=1
-pkgdesc="A free & open-source 2D sprite editor, made with the Godot Engine"
+pkgdesc="A free & open-source 2D sprite editor"
arch=('i686' 'pentium4' 'x86_64')
url="https://orama-interactive.itch.io/pixelorama"
_url="https://github.com/Orama-Interactive/Pixelorama"
@@ -15,7 +15,7 @@ makedepends=('curl' 'godot' 'unzip')
provides=('pixelorama')
conflicts=('pixelorama-bin' 'pixelorama-git')
source=("${_pkgname}-${pkgver}.tar.gz::${_url}/archive/v${pkgver}.tar.gz")
-sha512sums=('f9496d52a4053257ba0a87244b860a6540d02db1f1adc770a6b5753b01f2b908708f98d2c1981651f40c4910238ffb7ccec8a435d5cef88927ce50ba31b9f638')
+sha512sums=('5d10510ac4452c7a07e1c51a213839ac57af39d7c7f6f6c8c7bc166094c3af7cbb7d8eb343a64ca0cfd1ad269327fac17d0f93625a977cfa27be7663626e446f')
prepare() {
# Checks if the user's directory has the export templates
@@ -55,8 +55,8 @@ prepare() {
sed -i "s/enable_file_logging=true/enable_file_logging=false/" \
"${srcdir}/${_pkgname}-${pkgver}/project.godot"
- echo "#!/bin/sh" >> ${srcdir}/${pkgname}
- echo "exec /usr/lib/${pkgname}/${pkgname} \"\$@\"" >> ${srcdir}/${pkgname}
+ echo "#!/bin/sh" >> "${srcdir}/${_pkgname}-${pkgver}/Misc/Linux/${pkgname}.sh"
+ echo "exec /usr/lib/${pkgname}/${pkgname} \"\$@\"" >> "${srcdir}/${_pkgname}-${pkgver}/Misc/Linux/${pkgname}.sh"
}
build() {
@@ -66,15 +66,15 @@ build() {
}
package() {
- install -Dm755 "${srcdir}/${pkgname}" \
- "${pkgdir}/usr/bin/${pkgname}"
-
install -Dm755 "${srcdir}/${_pkgname}-${pkgver}/build/${pkgname}" \
"${pkgdir}/usr/lib/${pkgname}/${pkgname}"
install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/build/${pkgname}.pck" \
"${pkgdir}/usr/lib/${pkgname}/${pkgname}.pck"
+ install -Dm755 "${srcdir}/${_pkgname}-${pkgver}/Misc/Linux/${pkgname}.sh" \
+ "${pkgdir}/usr/bin/${pkgname}"
+
install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/Misc/Linux/com.orama_interactive.${_pkgname}.desktop" \
"${pkgdir}/usr/share/applications/com.orama_interactive.${pkgname}.desktop"