summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlpxl2020-12-15 09:59:52 -0300
committerlpxl2020-12-15 09:59:52 -0300
commit232f4c3067dd7ff21de83dd4350a66d0ce9dfb8c (patch)
tree568a6d3385d73256cc1ea6a601046efb23533570 /PKGBUILD
parent332d830de0d22beebf7574c19931d66d3c81f7b4 (diff)
downloadaur-232f4c3067dd7ff21de83dd4350a66d0ce9dfb8c.tar.gz
Update to 0.8.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 16c02cfb7522..2c40a7bf4668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Hilton Medeiros <medeiros.hilton@gmail.com>
_pkgname=Pixelorama
pkgname=pixelorama-bin
-pkgver=0.8.1
+pkgver=0.8.2
pkgrel=1
-pkgdesc="A free & open-source 2D sprite editor, made with the Godot Engine - precompiled binary"
+pkgdesc="A free & open-source 2D sprite editor, made with the Godot Engine"
arch=('i686' 'x86_64')
url="https://orama-interactive.itch.io/pixelorama"
license=('MIT')
-depends=('libpulse' 'alsa-lib' 'libxrandr' 'libglvnd' 'libxcursor' 'libxinerama' 'hicolor-icon-theme')
+depends=('libpulse' 'alsa-lib' 'libxi' 'libxrandr' 'libglvnd' 'libxcursor' 'libxinerama' 'hicolor-icon-theme')
provides=('pixelorama')
conflicts=('pixelorama' 'pixelorama-git')
source=("pixelorama.png" "com.orama_interactive.Pixelorama.appdata.xml" "com.orama_interactive.Pixelorama.desktop" "LICENSE")
source_i686=("$_pkgname-$pkgver-32bit.tar.gz::https://github.com/Orama-Interactive/$_pkgname/releases/download/v$pkgver/$_pkgname.Linux-32bit.tar.gz")
source_x86_64=("$_pkgname-$pkgver-64bit.tar.gz::https://github.com/Orama-Interactive/$_pkgname/releases/download/v$pkgver/$_pkgname.Linux-64bit.tar.gz")
sha256sums=('d92715606fb34e1863ecccd929675b742988ae55118146e2d9aee41c650b0933'
- 'bb07bee454c7bc6225f10574c7ff147fd1dc2c0f8ba903d7d8c0f2fa5caa02f0'
+ '971c3d5c7a9258419f14dae0b81c38e13b1dcabfbf1e578baaed86fde1c28fbe'
'5d9b6e1a44b07bfcfbf4fb3575d30df457571335c0c200f4130af51884f34b99'
'45efa21eefa4ff8c09842be56bce57d2cba6260c223b1a8c46d5f6ffc34958d7')
-sha256sums_i686=('5907635ebb883f4fefff86afe706a0ba15da0c8325f01ccfa74a8e8427dcc5e4')
-sha256sums_x86_64=('79fe8220b4b8f586999ae5476820699695e653c69224420528a0aa037b70948c')
+sha256sums_i686=('0884e2d0f4c00091c46d89ac4919fb30ca735b14b21889cde1494c66f85d4cdd')
+sha256sums_x86_64=('aed8bfc5ea68f144a2ee2673d5a3be6088979471e98cc84a6dd543de86b8e7c0')
package() {
install -d "$pkgdir/opt/$pkgname"
@@ -35,7 +35,5 @@ package() {
install -Dm644 "$srcdir/pixelorama.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps"
test "${CARCH}" == 'x86_64' && _pkgarch='x86_64' || _pkgarch='x86'
-# chmod +x ${pkgdir}/opt/${pkgname}/{*.so,${_pkgname}.${_pkgarch}}
-
ln -s /opt/${pkgname}/${_pkgname}.${_pkgarch} "$pkgdir/usr/bin/pixelorama"
}