summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordelta482015-08-13 13:13:28 -0500
committerdelta482015-08-13 13:13:28 -0500
commit7a6c6b5050b6d7d8b94d48c282d70ef9e742c5bb (patch)
tree1878afb7bbe3317fe9ae070229bc43779f23dd59 /PKGBUILD
downloadaur-7a6c6b5050b6d7d8b94d48c282d70ef9e742c5bb.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e095e5929e37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Mitch Bigelow <ipha00@gmail.com>
+# Contributor: delta48 <dark.magician.48[at]gmail[dot]com>
+
+pkgname=pixiewps-git
+_pkgname=pixiewps
+pkgver=r21.c849ad1
+pkgrel=1
+pkgdesc="Offline bruteforce of the WPS pin exploiting the low or non-existing entropy of some APs"
+arch=('i686' 'x86_64')
+url="https://github.com/wiire/pixiewps"
+license=('GPL')
+depends=('openssl')
+source=(git+https://github.com/wiire/pixiewps.git)
+#source=(https://github.com/wiire/pixiewps/archive/v$pkgver.tar.gz)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"/src/
+ sed -e 14,15d -e '16 s/m/D&/' -i Makefile
+ make
+}
+
+package() {
+ cd "$_pkgname"/src
+ make PREFIX="$pkgdir/usr" install
+}