summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2018-09-01 16:53:42 +0300
committerCaleb Maclennan2018-09-01 16:53:42 +0300
commit59b5316ed98f1d8affeac4295a631f7c6523d17b (patch)
treee607874f841e45526241de568772e7c9003d5303 /PKGBUILD
parent0b286f12aa4b8b3e360777768d4374387842907b (diff)
downloadaur-59b5316ed98f1d8affeac4295a631f7c6523d17b.tar.gz
Cleanup bash shell quoting using shellharden
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5e1a6e5aefb..fbe6826e4dbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,21 +13,21 @@ license=('GPL')
depends=('openssl' 'portaudio' 'speex' 'alsa-lib' 'libsamplerate' 'util-linux' 'ffmpeg' 'libsrtp' 'opus')
makedepends=('e2fsprogs' 'python')
optdepends=('alsa-lib' 'e2fsprogs' 'python')
-source=("http://www.pjsip.org/release/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
+source=("http://www.pjsip.org/release/$pkgver/$pkgname-$pkgver.tar.bz2")
sha256sums=('9c2c828abab7626edf18e04b041ef274bfaa86f99adf2c25ff56f1509e813772')
build() {
- cd "${pkgname}-${pkgver}"
- export CXXFLAGS="${CXXFLAGS} -fPIC -march=native"
- export CFLAGS="${CXXFLAGS} -DNDEBUG"
+ cd "$pkgname-$pkgver"
+ export CXXFLAGS="$CXXFLAGS -fPIC -march=native"
+ export CFLAGS="$CXXFLAGS -DNDEBUG"
./configure --prefix=/usr --with-external-speex --with-external-srtp --with-external-pa --with-external-gsm --disable-oss --enable-shared --disable-opencore-amr --disable-v4l2 --disable-video --disable-sound
- echo "#define PJ_HAS_IPV6 1" >> "${srcdir}/${pkgname}-${pkgver}/pjlib/include/pj/config_site.h"
+ echo "#define PJ_HAS_IPV6 1" >> "$srcdir/$pkgname-$pkgver/pjlib/include/pj/config_site.h"
make -j1 dep
make -j1
}
package() {
- cd "${pkgname}-${pkgver}"
- make -j1 DESTDIR=${pkgdir} install
- install -D -m755 pjsip-apps/bin/pjsua-*gnu ${pkgdir}/usr/bin/pjsua
+ cd "$pkgname-$pkgver"
+ make -j1 DESTDIR="$pkgdir" install
+ install -D -m755 pjsip-apps/bin/pjsua-*gnu "$pkgdir"/usr/bin/pjsua
}