summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli2019-04-14 23:48:47 +0200
committerCaleb Maclennan2019-06-18 15:56:55 +0300
commit77d4924a9a36b0bdc4877b8e8baedd89dfb7ac8c (patch)
tree7af8dd0c68e7d234943b1456019c2a467d844357 /PKGBUILD
parentbcc191f13714ae4101406ec52276bbace68fa149 (diff)
downloadaur-77d4924a9a36b0bdc4877b8e8baedd89dfb7ac8c.tar.gz
disable libwebrtc on i686 to fix illegal instructions
Both Parabola and archlinux32 whish to support all i686 machines that don't have SSE2: - Parabola's minimum system requirements states that: "Parabola GNU/Linux-libre should run on any i686 compatible machine [...]"[1] Wikipedia states that i686 has MMX and SSE[2] but doesn't mention SSE2 as a requirement[2]. - Archlinux32 states: "Currently some i686 packages require SSE2 - which is a bug we're trying to solve."[3] References: ----------- [1]https://wiki.parabola.nu/Beginners%27_guide#Minimum_system_requirements [2]https://en.wikipedia.org/wiki/P6_(microarchitecture) [3]https://archlinux32.org/architecture/ Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35435828b2db..297adb32c64a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=pjproject
pkgver=2.8
-pkgrel=2
+pkgrel=3
pkgdesc='Open source SIP stack and media stack'
arch=('i686' 'x86_64' 'armv7h')
url='http://www.pjsip.org/'
@@ -19,8 +19,12 @@ sha256sums=('503d0bd7f9f13dc1492ac9b71b761b1089851fbb608b9a13996edc3c42006f79')
build() {
cd "$pkgname-$pkgver"
export CXXFLAGS="$CXXFLAGS -fPIC"
+ if [ "$CARCH" = "i686" ]; then
+ export CXXFLAGS="$CXXFLAGS -march=i686"
+ arch_opts="--disable-libwebrtc"
+ fi
export CFLAGS="$CXXFLAGS -DNDEBUG"
- ./configure --prefix=/usr --with-external-speex --with-external-srtp --with-external-pa --with-external-gsm --disable-oss --enable-shared --disable-opencore-amr --disable-v4l2 --disable-video --disable-sound
+ ./configure --prefix=/usr --with-external-speex --with-external-srtp --with-external-pa --with-external-gsm --disable-oss --enable-shared --disable-opencore-amr --disable-v4l2 --disable-video --disable-sound ${arch_opts}
echo "#define PJ_HAS_IPV6 1" >> "$srcdir/$pkgname-$pkgver/pjlib/include/pj/config_site.h"
make -j1 dep
make -j1