summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli2019-04-14 23:33:27 +0200
committerCaleb Maclennan2019-06-18 15:56:55 +0300
commitbcc191f13714ae4101406ec52276bbace68fa149 (patch)
tree23c3f31136ebe4a0a0c3300eb6764ddcd19a045e /PKGBUILD
parentecaed25566dc6b586e6de4e5a5738f78f71de250 (diff)
downloadaur-bcc191f13714ae4101406ec52276bbace68fa149.tar.gz
Fix illegal instructions on x86_64 by disabling -march=native
Before this package was built with -march=native, so if you build it on a machine with a processor that supports avx (Advanced Vector Extensions), libpjsip.so.2 ended up with vpxor instructions that don't work anymore on machines with a processor that do not have such extension, and would result in an illegal instruction at asterisk startup on such machines. Signed-off-by: Denis 'GNUtoo' Carikli GNUtoo@cyberdimension.org PKGBUILD | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86586427f94e..35435828b2db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=pjproject
pkgver=2.8
-pkgrel=1
+pkgrel=2
pkgdesc='Open source SIP stack and media stack'
arch=('i686' 'x86_64' 'armv7h')
url='http://www.pjsip.org/'
@@ -18,7 +18,7 @@ sha256sums=('503d0bd7f9f13dc1492ac9b71b761b1089851fbb608b9a13996edc3c42006f79')
build() {
cd "$pkgname-$pkgver"
- export CXXFLAGS="$CXXFLAGS -fPIC -march=native"
+ export CXXFLAGS="$CXXFLAGS -fPIC"
export CFLAGS="$CXXFLAGS -DNDEBUG"
./configure --prefix=/usr --with-external-speex --with-external-srtp --with-external-pa --with-external-gsm --disable-oss --enable-shared --disable-opencore-amr --disable-v4l2 --disable-video --disable-sound
echo "#define PJ_HAS_IPV6 1" >> "$srcdir/$pkgname-$pkgver/pjlib/include/pj/config_site.h"