summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12017-08-23 00:32:31 +0800
committerChocobo12017-08-23 00:51:11 +0800
commit96a9c65f0c6f51a91a931199bbeab67cc43ad5ea (patch)
tree2ae95de0031d110febe7f5e1d56fdbd15342d087 /PKGBUILD
downloadaur-96a9c65f0c6f51a91a931199bbeab67cc43ad5ea.tar.gz
newpkg: pkg-config-git 0.29.2.r1.g2dd2b19-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58abc458a4e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=pkg-config-git
+pkgver=0.29.2.r1.g2dd2b19
+pkgrel=1
+pkgdesc="Provides useful functions commonly found on BSD systems"
+arch=('i686' 'x86_64')
+url="https://www.freedesktop.org/wiki/Software/pkg-config/"
+license=('GPL2')
+depends=('glibc' 'glib2')
+makedepends=('git')
+provides=('pkgconfig')
+conflicts=('pkgconfig')
+source=("git+https://anongit.freedesktop.org/git/pkg-config.git"
+ "0001-Workaround-error-m4_copy.patch")
+sha256sums=('SKIP'
+ '03e1c1a997590b82c0922fca86c7be5ee85d04181c6f2ce020bdbe53c7f1b47b')
+
+
+prepare() {
+ cd "pkg-config"
+
+ patch -Np1 -i "$srcdir/0001-Workaround-error-m4_copy.patch"
+}
+
+pkgver() {
+ cd "pkg-config"
+
+ git describe --long --tags | sed 's/^pkg-config-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "pkg-config"
+
+ ./autogen.sh --no-configure
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "pkg-config"
+
+ make check
+}
+
+package() {
+ cd "pkg-config"
+
+ make DESTDIR="$pkgdir" install
+}