summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbudRich2023-02-09 21:10:06 +0000
committerbudRich2023-02-09 21:10:06 +0000
commit97c5a91cb120d3017bc391e0621b50e911e4649e (patch)
tree4078afbc8489fbc7fc009a24aac6422e7290b1a7 /PKGBUILD
downloadaur-97c5a91cb120d3017bc391e0621b50e911e4649e.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f1d19c21e48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: budRich von budlabs
+# Contributor: budRich
+
+pkgname=pkg-listn
+pkgver=0.1
+pkgrel=1
+pkgdesc='Manage linux packages with a textfile'
+arch=('any')
+url='https://github.com/budRich/pkg-listn'
+# url='file:///home/bud/git/bud/pkg-listn'
+license=('Unlicense')
+depends=('bash>=4.0.0' 'sed')
+makedepends=(m4)
+optdepends=('yay: AUR helper' 'paru: AUR helper')
+conflicts=()
+source=("${url}/archive/refs/tags/v${pkgver}.tar.gz")
+provides=()
+sha256sums=('SKIP')
+
+package() {
+ cd "${pkgname}-$pkgver"
+
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
+}